1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 14:18:05 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.23/004-extra_optimization.patch
juhosg ac85de1ef4 [kernel] generic-2.6/2.6.23: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14448 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-02-08 19:11:53 +00:00

13 lines
393 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -508,6 +508,9 @@ CFLAGS += $(call cc-option, -fn
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)