1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 14:03:41 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.23/403-ledtrig_netdev.patch
juhosg ac85de1ef4 [kernel] generic-2.6/2.6.23: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14448 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-02-08 19:11:53 +00:00

22 lines
734 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -150,4 +150,11 @@ config LEDS_TRIGGER_DEFAULT_ON
This allows LEDs to be initialised in the ON state.
If unsure, say Y.
+config LEDS_TRIGGER_NETDEV
+ tristate "LED Netdev Trigger"
+ depends on LEDS_TRIGGERS
+ help
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -25,3 +25,4 @@ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += l
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o