mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 20:34:05 +02:00
a210854b74
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16048 3c298f89-4303-0410-b956-a3cf2f4a3e73
34 lines
1.0 KiB
Diff
34 lines
1.0 KiB
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -227,6 +227,19 @@ config LEDS_BD2802
|
|
This option enables support for BD2802GU RGB LED driver chips
|
|
accessed via the I2C bus.
|
|
|
|
+config LEDS_GTA02_VIBRATOR
|
|
+ tristate "Vibrator Support for the Openmoko Freerunner GSM phone"
|
|
+ depends on LEDS_CLASS && MACH_NEO1973_GTA02
|
|
+ help
|
|
+ This option enables support for the vibrator on the Openmoko Freerunner.
|
|
+
|
|
+config LEDS_GTA02
|
|
+ tristate "LED Support for the Openmoko Freerunner GSM phone"
|
|
+ depends on LEDS_CLASS && MACH_NEO1973_GTA02
|
|
+ help
|
|
+ This option enables support for the LEDs on the Openmoko Freerunner.
|
|
+
|
|
+
|
|
comment "LED Triggers"
|
|
|
|
config LEDS_TRIGGERS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -30,6 +30,8 @@ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
|
|
|
|
# LED SPI Drivers
|
|
obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o
|
|
+obj-$(CONFIG_LEDS_GTA02_VIBRATOR) += leds-gta02-vibrator.o
|
|
+obj-$(CONFIG_LEDS_GTA02) += leds-gta02.o
|
|
|
|
# LED Triggers
|
|
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
|