mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 19:27:31 +02:00
414e59d258
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19358 3c298f89-4303-0410-b956-a3cf2f4a3e73
39 lines
1.2 KiB
Diff
39 lines
1.2 KiB
Diff
From 5777849c788174f7de3bd9e14105af52f916ef5b Mon Sep 17 00:00:00 2001
|
|
From: Lars-Peter Clausen <lars@metafoo.de>
|
|
Date: Mon, 11 Jan 2010 04:29:38 +0100
|
|
Subject: [PATCH] /opt/Projects/openwrt/target/linux/xburst/patches-2.6.31/051-fb.patch
|
|
|
|
---
|
|
drivers/video/Kconfig | 9 +++++++++
|
|
drivers/video/Makefile | 1 +
|
|
2 files changed, 10 insertions(+), 0 deletions(-)
|
|
|
|
--- a/drivers/video/Kconfig
|
|
+++ b/drivers/video/Kconfig
|
|
@@ -2160,6 +2160,15 @@ config FB_BROADSHEET
|
|
and could also have been called by other names when coupled with
|
|
a bridge adapter.
|
|
|
|
+config FB_JZ4740
|
|
+ tristate "JZ47420/JZ4740 LCD framebuffer support"
|
|
+ depends on FB
|
|
+ select FB_SYS_FILLRECT
|
|
+ select FB_SYS_COPYAREA
|
|
+ select FB_SYS_IMAGEBLIT
|
|
+ help
|
|
+ Framebuffer support for the JZ4720 and JZ4740 SoC.
|
|
+
|
|
source "drivers/video/omap/Kconfig"
|
|
|
|
source "drivers/video/backlight/Kconfig"
|
|
--- a/drivers/video/Makefile
|
|
+++ b/drivers/video/Makefile
|
|
@@ -128,6 +128,7 @@ obj-$(CONFIG_XEN_FBDEV_FRONTEND) += xen
|
|
obj-$(CONFIG_FB_CARMINE) += carminefb.o
|
|
obj-$(CONFIG_FB_MB862XX) += mb862xx/
|
|
obj-$(CONFIG_FB_MSM) += msm/
|
|
+obj-$(CONFIG_FB_JZ4740) += jz4740_fb.o
|
|
|
|
# Platform or fallback drivers go here
|
|
obj-$(CONFIG_FB_UVESA) += uvesafb.o
|