1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 12:46:27 +03:00
openwrt-xburst/target/linux/generic-2.4/patches/010-disable_old_squashfs_compatibility.patch
kaloz 984ce03b6a upgrade to squashfs 3.0
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3431 3c298f89-4303-0410-b956-a3cf2f4a3e73
2006-03-21 13:41:09 +00:00

26 lines
930 B
Diff

diff -Nur linux-2.4.32/fs/squashfs/Makefile linux-2.4.32-owrt/fs/squashfs/Makefile
--- linux-2.4.32/fs/squashfs/Makefile 2006-03-21 13:47:50.000000000 +0100
+++ linux-2.4.32-owrt/fs/squashfs/Makefile 2006-03-21 13:48:49.000000000 +0100
@@ -4,7 +4,7 @@
O_TARGET := squashfs.o
-obj-y := inode.o squashfs2_0.o LzmaDecode.o
+obj-y := inode.o LzmaDecode.o
obj-m := $(O_TARGET)
diff -Nur linux-2.4.32/fs/squashfs/squashfs.h linux-2.4.32-owrt/fs/squashfs/squashfs.h
--- linux-2.4.32/fs/squashfs/squashfs.h 2006-03-21 13:06:10.000000000 +0100
+++ linux-2.4.32-owrt/fs/squashfs/squashfs.h 2006-03-21 13:48:36.000000000 +0100
@@ -24,6 +24,9 @@
#ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#endif
+#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#endif
#ifdef SQUASHFS_TRACE
#define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)
#else