1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 19:39:55 +03:00
openwrt-xburst/target/linux/etrax/patches-2.6.30/500-i2c_gvc.patch
claudio 8bbe73f1de [etrax] Improve i2c driver slave delay, thanks to Fabrizio Sciarra that provide it
* support for master/slave delay  (provided patch)
  * remove some printk that spam logs
  * introduce new symbols ETRAX_I2C_DYN_ALLOC and ETRAX_I2C_SLAVE_DELAY 
  * cleanup a bit the driver
  * dump release number


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17954 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-10-06 09:20:30 +00:00

59 lines
2.3 KiB
Diff

Index: linux-2.6.30.8/arch/cris/arch-v10/drivers/Kconfig
===================================================================
--- linux-2.6.30.8.orig/arch/cris/arch-v10/drivers/Kconfig 2009-10-02 11:31:49.000000000 +0200
+++ linux-2.6.30.8/arch/cris/arch-v10/drivers/Kconfig 2009-10-06 10:36:23.000000000 +0200
@@ -450,11 +450,31 @@
i2c_arg = I2C_READARG(STA013_READ_ADDR, reg);
val = ioctl(fd, _IO(ETRAXI2C_IOCTYPE, I2C_READREG), i2c_arg);
+config ETRAX_I2C_GVC
+ bool "I2C GVC support"
+ depends on ETRAX_ARCH_V10 && !ETRAX_I2C
+ select ETRAX_I2C_USES_PB_NOT_PB_I2C
+ help
+ Enables an I2C driver with Geert Vancompernolle improvement.
+
+config ETRAX_I2C_SLAVE_DELAY
+ bool "I2C Slave delay support"
+ depends on ETRAX_I2C_GVC && EXPERIMENTAL
+ help
+ Enable this to enhanced master/slave dialog
+ Improvement by Positive Going (www.positivegoing.it) and BK srl (www.b-k.it)
+
+config ETRAX_I2C_DYN_ALLOC
+ bool "I2C major device dynamic alloc"
+ depends on ETRAX_I2C_GVC && EXPERIMENTAL
+ help
+ Enable this to dynamicaly alloc major i2c device number
+
# this is true for most products since PB-I2C seems to be somewhat
# flawed..
config ETRAX_I2C_USES_PB_NOT_PB_I2C
bool "I2C uses PB not PB-I2C"
- depends on ETRAX_I2C
+ depends on ETRAX_I2C || ETRAX_I2C_GVC
help
Select whether to use the special I2C mode in the PB I/O register or
not. This option needs to be selected in order to use some drivers
@@ -478,7 +498,7 @@
config ETRAX_I2C_EEPROM
bool "I2C EEPROM (non-volatile RAM) support"
- depends on ETRAX_I2C
+ depends on ETRAX_I2C || ETRAX_I2C_GVC
help
Enables I2C EEPROM (non-volatile RAM) on PB0 and PB1 using the I2C
driver. Select size option: Probed, 2k, 8k, 16k.
Index: linux-2.6.30.8/arch/cris/arch-v10/drivers/Makefile
===================================================================
--- linux-2.6.30.8.orig/arch/cris/arch-v10/drivers/Makefile 2009-10-02 11:31:14.000000000 +0200
+++ linux-2.6.30.8/arch/cris/arch-v10/drivers/Makefile 2009-10-02 11:31:50.000000000 +0200
@@ -4,6 +4,7 @@
obj-$(CONFIG_ETRAX_AXISFLASHMAP) += axisflashmap.o
obj-$(CONFIG_ETRAX_I2C) += i2c.o
+obj-$(CONFIG_ETRAX_I2C_GVC) += i2c_gvc.o
obj-$(CONFIG_ETRAX_I2C_EEPROM) += eeprom.o
obj-$(CONFIG_ETRAX_GPIO) += gpio.o
obj-$(CONFIG_ETRAX_DS1302) += ds1302.o