mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 17:53:09 +02:00
2048e10433
This adds u-boot for nbg460n ar71xx target, as it is required as second stage bootloader. Signed-off-by: Michael Kurz <michi.kurz@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24418 3c298f89-4303-0410-b956-a3cf2f4a3e73
23 lines
1.0 KiB
Diff
23 lines
1.0 KiB
Diff
diff -ur u-boot-2010.03/drivers/net/Makefile u-boot-nbg/drivers/net/Makefile
|
|
--- u-boot-2010.03/drivers/net/Makefile 2010-03-31 23:54:39.000000000 +0200
|
|
+++ u-boot-nbg/drivers/net/Makefile 2010-04-19 23:30:01.000000000 +0200
|
|
@@ -27,6 +27,7 @@
|
|
|
|
COBJS-$(CONFIG_DRIVER_3C589) += 3c589.o
|
|
COBJS-$(CONFIG_PPC4xx_EMAC) += 4xx_enet.o
|
|
+COBJS-$(CONFIG_AG71XX) += ag71xx.o
|
|
COBJS-$(CONFIG_DRIVER_AT91EMAC) += at91_emac.o
|
|
COBJS-$(CONFIG_DRIVER_AX88180) += ax88180.o
|
|
COBJS-$(CONFIG_BCM570x) += bcm570x.o bcm570x_autoneg.o 5701rls.o
|
|
diff -ur u-boot-2010.03/include/netdev.h u-boot-nbg/include/netdev.h
|
|
--- u-boot-2010.03/include/netdev.h 2010-03-31 23:54:39.000000000 +0200
|
|
+++ u-boot-nbg/include/netdev.h 2010-05-02 11:30:58.000000000 +0200
|
|
@@ -42,6 +42,7 @@
|
|
|
|
/* Driver initialization prototypes */
|
|
int au1x00_enet_initialize(bd_t*);
|
|
+int ag71xx_register(bd_t * bis, char *phyname[], u16 phyid[], u16 phyfixed[]);
|
|
int at91emac_register(bd_t *bis, unsigned long iobase);
|
|
int bfin_EMAC_initialize(bd_t *bis);
|
|
int cs8900_initialize(u8 dev_num, int base_addr);
|