1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 15:11:29 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.27/402-ledtrig_netdev.patch
juhosg ae2566d99c [kernel] refresh patches against 2.6.27 final
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12987 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-10-15 19:30:21 +00:00

22 lines
715 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -216,4 +216,11 @@ config LEDS_TRIGGER_MORSE
tristate "LED Morse Trigger"
depends on LEDS_TRIGGERS
+config LEDS_TRIGGER_NETDEV
+ tristate "LED Netdev Trigger"
+ depends on LEDS_TRIGGERS
+ help
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -31,3 +31,4 @@ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += l
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o