1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 14:37:07 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.31/004-extra_optimization.patch
2009-09-22 18:00:35 +00:00

22 lines
592 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -521,7 +521,7 @@ all: vmlinux
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
KBUILD_CFLAGS += -Os
else
-KBUILD_CFLAGS += -O2
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
endif
include $(srctree)/arch/$(SRCARCH)/Makefile
@@ -559,6 +559,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)