1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 14:44:37 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.31/970-ocf_kbuild_integration.patch
mirko c3fd35e780 add generic patchset levelled up to 2.6.31-rc6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17351 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-08-22 12:46:12 +00:00

26 lines
534 B
Diff

--- a/crypto/Kconfig
+++ b/crypto/Kconfig
@@ -794,6 +794,8 @@ config CRYPTO_ANSI_CPRNG
for cryptographic modules. Uses the Algorithm specified in
ANSI X9.31 A.2.4
+source "crypto/ocf/Kconfig"
+
source "drivers/crypto/Kconfig"
endif # if CRYPTO
--- a/crypto/Makefile
+++ b/crypto/Makefile
@@ -86,6 +86,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
#
+# OCF
+#
+obj-$(CONFIG_OCF_OCF) += ocf/
+
+#
# generic algorithms and the async_tx api
#
obj-$(CONFIG_XOR_BLOCKS) += xor.o