mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 22:44:39 +02:00
5fb5b4483b
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29008 3c298f89-4303-0410-b956-a3cf2f4a3e73
27 lines
942 B
Diff
27 lines
942 B
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -379,6 +379,13 @@ config LEDS_TRIGGERS
|
|
These triggers allow kernel events to drive the LEDs and can
|
|
be configured via sysfs. If unsure, say Y.
|
|
|
|
+config LEDS_WNDR3700_USB
|
|
+ tristate "NETGEAR WNDR3700 USB LED driver"
|
|
+ depends on LEDS_CLASS && AR71XX_MACH_WNDR3700
|
|
+ help
|
|
+ This option enables support for the USB LED found on the
|
|
+ NETGEAR WNDR3700 board.
|
|
+
|
|
comment "LED Triggers"
|
|
|
|
config LEDS_TRIGGER_TIMER
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -33,6 +33,7 @@ obj-$(CONFIG_LEDS_DA903X) += leds-da903
|
|
obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
|
|
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
|
|
obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
|
|
+obj-${CONFIG_LEDS_WNDR3700_USB} += leds-wndr3700-usb.o
|
|
obj-$(CONFIG_LEDS_REGULATOR) += leds-regulator.o
|
|
obj-$(CONFIG_LEDS_INTEL_SS4200) += leds-ss4200.o
|
|
obj-$(CONFIG_LEDS_LT3593) += leds-lt3593.o
|