mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-08 18:04:38 +02:00
8e6fbc03d1
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2439 3c298f89-4303-0410-b956-a3cf2f4a3e73
100 lines
2.9 KiB
Diff
100 lines
2.9 KiB
Diff
diff -urN linux.old/Makefile linux.dev/Makefile
|
|
--- linux.old/Makefile 2005-08-26 13:41:41.689634168 +0200
|
|
+++ linux.dev/Makefile 2005-08-26 13:44:34.233403528 +0200
|
|
@@ -17,9 +17,9 @@
|
|
FINDHPATH = $(HPATH)/asm $(HPATH)/linux $(HPATH)/scsi $(HPATH)/net $(HPATH)/math-emu
|
|
|
|
HOSTCC = gcc
|
|
-HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
|
|
+HOSTCFLAGS = -Wall -Wstrict-prototypes -Os -fomit-frame-pointer
|
|
|
|
-CROSS_COMPILE =
|
|
+CROSS_COMPILE=
|
|
|
|
#
|
|
# Include the make variables (CC, etc...)
|
|
@@ -89,6 +89,8 @@
|
|
# standard CFLAGS
|
|
#
|
|
|
|
+check_gcc = $(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi)
|
|
+
|
|
CPPFLAGS := -D__KERNEL__ -I$(HPATH)
|
|
|
|
CFLAGS := $(CPPFLAGS) -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
|
|
@@ -91,8 +93,10 @@
|
|
|
|
CPPFLAGS := -D__KERNEL__ -I$(HPATH)
|
|
|
|
-CFLAGS := $(CPPFLAGS) -Wall -Wstrict-prototypes -Wno-trigraphs -O2 \
|
|
+CFLAGS := $(CPPFLAGS) -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
|
|
-fno-strict-aliasing -fno-common
|
|
+
|
|
+
|
|
ifndef CONFIG_FRAME_POINTER
|
|
CFLAGS += -fomit-frame-pointer
|
|
endif
|
|
@@ -100,6 +105,12 @@
|
|
endif
|
|
AFLAGS := -D__ASSEMBLY__ $(CPPFLAGS)
|
|
|
|
+CFLAGS += $(call check_gcc, -funit-at-a-time,)
|
|
+
|
|
+
|
|
+
|
|
+
|
|
+
|
|
#
|
|
# ROOT_DEV specifies the default root-device when making the image.
|
|
# This can be either FLOPPY, CURRENT, /dev/xxxx or empty, in which case
|
|
diff -urN linux.old/arch/mips/Makefile linux.dev/arch/mips/Makefile
|
|
--- linux.old/arch/mips/Makefile 2005-11-07 23:12:50.582887000 +0100
|
|
+++ linux.dev/arch/mips/Makefile 2005-11-07 21:57:08.537629000 +0100
|
|
@@ -46,10 +46,10 @@
|
|
GCCFLAGS := -I $(TOPDIR)/include/asm/gcc
|
|
GCCFLAGS += -G 0 -mno-abicalls -fno-pic -pipe
|
|
GCCFLAGS += $(call check_gcc, -finline-limit=100000,)
|
|
-LINKFLAGS += -G 0 -static -n
|
|
-MODFLAGS += -mlong-calls
|
|
+LINKFLAGS += -G 0 -static -n -nostdlib
|
|
+MODFLAGS += -mlong-calls -fno-common
|
|
|
|
-ifdef CONFIG_DEBUG_INFO
|
|
+ifdef CONFIG_REMOTE_DEBUG
|
|
GCCFLAGS += -g
|
|
ifdef CONFIG_SB1XXX_CORELIS
|
|
GCCFLAGS += -mno-sched-prolog -fno-omit-frame-pointer
|
|
@@ -71,13 +71,13 @@
|
|
set_gccflags = $(shell \
|
|
while :; do \
|
|
cpu=$(1); isa=-$(2); \
|
|
- for gcc_opt in -march= -mcpu=; do \
|
|
+ for gcc_opt in -march= -mtune=; do \
|
|
$(CC) $$gcc_opt$$cpu $$isa -S -o /dev/null \
|
|
-xc /dev/null > /dev/null 2>&1 && \
|
|
break 2; \
|
|
done; \
|
|
cpu=$(3); isa=-$(4); \
|
|
- for gcc_opt in -march= -mcpu=; do \
|
|
+ for gcc_opt in -march= -mtune=; do \
|
|
$(CC) $$gcc_opt$$cpu $$isa -S -o /dev/null \
|
|
-xc /dev/null > /dev/null 2>&1 && \
|
|
break 2; \
|
|
@@ -92,7 +92,7 @@
|
|
fi; \
|
|
gas_abi=-Wa,-32; gas_cpu=$$cpu; gas_isa=-Wa,$$isa; \
|
|
while :; do \
|
|
- for gas_opt in -Wa,-march= -Wa,-mcpu=; do \
|
|
+ for gas_opt in -Wa,-march= -Wa,-mtune=; do \
|
|
$(CC) $$gas_abi $$gas_opt$$cpu $$gas_isa -Wa,-Z -c \
|
|
-o /dev/null -xassembler /dev/null > /dev/null 2>&1 && \
|
|
break 2; \
|
|
@@ -174,6 +174,7 @@
|
|
endif
|
|
|
|
AFLAGS += $(GCCFLAGS)
|
|
+ASFLAGS += $(GCCFLAGS)
|
|
CFLAGS += $(GCCFLAGS)
|
|
|
|
LD += -m $(ld-emul)
|