1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 10:37:07 +03:00
openwrt-xburst/target/linux/orion/patches/200-dt2_board_support.patch
thepeople f286b80a74 Switch Marvell Orion CPU to kernel 2.6.32 plus LED support for all LEDs
on LinkSys WRT350Nv2.

Signed-off by: Matthias Buecher <mail@maddes.net> and Dirk Teurlings
<info@upexia.nl>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20185 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-03-14 01:41:52 +00:00

24 lines
798 B
Diff

--- a/arch/arm/mach-orion5x/Kconfig
+++ b/arch/arm/mach-orion5x/Kconfig
@@ -16,6 +16,13 @@ config MACH_RD88F5182
Say 'Y' here if you want your kernel to support the
Marvell Orion-NAS (88F5182) RD2
+config MACH_DT2
+ bool "Freecom DataTank Gateway"
+ select I2C_BOARDINFO
+ help
+ Say 'Y' here if you want your kernel to support the
+ Freecom DataTank Gateway
+
config MACH_KUROBOX_PRO
bool "KuroBox Pro"
select I2C_BOARDINFO
--- a/arch/arm/mach-orion5x/Makefile
+++ b/arch/arm/mach-orion5x/Makefile
@@ -20,3 +20,4 @@ obj-$(CONFIG_MACH_WNR854T) += wnr854t-se
obj-$(CONFIG_MACH_RD88F5181L_GE) += rd88f5181l-ge-setup.o
obj-$(CONFIG_MACH_RD88F5181L_FXO) += rd88f5181l-fxo-setup.o
obj-$(CONFIG_MACH_RD88F6183AP_GE) += rd88f6183ap-ge-setup.o
+obj-$(CONFIG_MACH_DT2) += dt2-setup.o