mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 20:50:20 +02:00
1d8d224223
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18019 3c298f89-4303-0410-b956-a3cf2f4a3e73
17 lines
619 B
Diff
17 lines
619 B
Diff
--- a/Makefile.rules
|
|
+++ b/Makefile.rules
|
|
@@ -506,11 +506,13 @@ endif
|
|
#--------------------------------------------------------------------
|
|
|
|
ifeq ($(HOST_OS),Darwin)
|
|
+ ifndef DARWIN_VERSION
|
|
DARWIN_VERSION := `sw_vers -productVersion`
|
|
# Strip a number like 10.4.7 to 10.4
|
|
DARWIN_VERSION := $(shell echo $(DARWIN_VERSION)| sed -E 's/(10.[0-9]).*/\1/')
|
|
# Get "4" out of 10.4 for later pieces in the makefile.
|
|
DARWIN_MAJVERS := $(shell echo $(DARWIN_VERSION)| sed -E 's/10.([0-9]).*/\1/')
|
|
+ endif
|
|
|
|
SharedLinkOptions=-Wl,-flat_namespace -Wl,-undefined -Wl,suppress \
|
|
-dynamiclib
|