1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-18 21:58:03 +03:00
openwrt-xburst/target/linux/xburst/patches-2.6.32/106-gpio-charger.patch
lars 297f147eae [xburst] Seperate charger logic from battery driver
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19504 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-02-03 13:16:23 +00:00

22 lines
787 B
Diff

--- a/drivers/power/Makefile 2010-02-03 13:16:32.000000000 +0100
+++ b/drivers/power/Makefile 2010-02-01 14:55:46.000000000 +0100
@@ -30,3 +30,4 @@
obj-$(CONFIG_BATTERY_MAX17040) += max17040_battery.o
obj-$(CONFIG_CHARGER_PCF50633) += pcf50633-charger.o
obj-$(CONFIG_BATTERY_JZ4740) += jz4740-battery.o
+obj-$(CONFIG_CHARGER_GPIO) += gpio-charger.o
--- a/drivers/power/Kconfig 2010-02-03 13:16:32.000000000 +0100
+++ b/drivers/power/Kconfig 2010-02-01 14:58:24.000000000 +0100
@@ -121,4 +121,11 @@
This driver can be build as a module. If so, the module will be
called jz4740-battery.
+config CHARGER_GPIO
+ tristate "GPIO charger"
+ depends on GPIOLIB
+ help
+ Say Y to include support for chargers indicating their status through
+ a GPIO pin.
+
endif # POWER_SUPPLY