mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:20:37 +02:00
17c7b6c3fd
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8653 3c298f89-4303-0410-b956-a3cf2f4a3e73
122 lines
2.9 KiB
Diff
122 lines
2.9 KiB
Diff
diff -urN linux-2.6.22.1.old/arch/arm/mach-at91/Makefile linux-2.6.22.1/arch/arm/mach-at91/Makefile
|
|
--- linux-2.6.22.1.old/arch/arm/mach-at91/Makefile 2007-07-29 06:46:13.000000000 +0200
|
|
+++ linux-2.6.22.1/arch/arm/mach-at91/Makefile 2007-07-29 06:54:19.000000000 +0200
|
|
@@ -53,7 +53,7 @@
|
|
led-$(CONFIG_MACH_CSB637) += leds.o
|
|
led-$(CONFIG_MACH_KB9200) += leds.o
|
|
led-$(CONFIG_MACH_KAFA) += leds.o
|
|
-led-$(CONFIG_MACH_VLINK) += leds.o
|
|
+led-$(CONFIG_MACH_VLINK) += vlink_leds.o
|
|
obj-$(CONFIG_LEDS) += $(led-y)
|
|
|
|
# VGA support
|
|
diff -urN linux-2.6.22.1.old/arch/arm/mach-at91/vlink_leds.c linux-2.6.22.1/arch/arm/mach-at91/vlink_leds.c
|
|
--- linux-2.6.22.1.old/arch/arm/mach-at91/vlink_leds.c 1970-01-01 01:00:00.000000000 +0100
|
|
+++ linux-2.6.22.1/arch/arm/mach-at91/vlink_leds.c 2007-07-29 06:54:58.000000000 +0200
|
|
@@ -0,0 +1,105 @@
|
|
+/*
|
|
+ * LED driver for Atmel AT91-based boards.
|
|
+ *
|
|
+ * Copyright (C) SAN People (Pty) Ltd
|
|
+ * Modified for FDL VersaLink Copyright (C) Guthrie Consulting
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License
|
|
+ * as published by the Free Software Foundation; either version
|
|
+ * 2 of the License, or (at your option) any later version.
|
|
+*/
|
|
+
|
|
+#include <linux/kernel.h>
|
|
+#include <linux/module.h>
|
|
+#include <linux/init.h>
|
|
+
|
|
+#include <asm/mach-types.h>
|
|
+#include <asm/leds.h>
|
|
+#include <asm/arch/board.h>
|
|
+#include <asm/arch/gpio.h>
|
|
+
|
|
+
|
|
+static inline void at91_led_on(unsigned int led)
|
|
+{
|
|
+ at91_set_gpio_value(led, 0);
|
|
+}
|
|
+
|
|
+static inline void at91_led_off(unsigned int led)
|
|
+{
|
|
+ at91_set_gpio_value(led, 1);
|
|
+}
|
|
+
|
|
+static inline void at91_led_toggle(unsigned int led)
|
|
+{
|
|
+ unsigned long is_off = at91_get_gpio_value(led);
|
|
+ if (is_off) {
|
|
+ at91_led_on(led);
|
|
+ at91_led_off(at91_leds_cpu);
|
|
+ }
|
|
+ else {
|
|
+ at91_led_on(at91_leds_cpu);
|
|
+ at91_led_off(led);
|
|
+ }
|
|
+}
|
|
+
|
|
+
|
|
+/*
|
|
+ * Handle LED events.
|
|
+ */
|
|
+
|
|
+/*
|
|
+ * VersaLink has a single bi-coloured LED which changes colour when the
|
|
+ * polarity is reversed
|
|
+ */
|
|
+static void at91_leds_event(led_event_t evt)
|
|
+{
|
|
+ unsigned long flags;
|
|
+
|
|
+ local_irq_save(flags);
|
|
+
|
|
+ switch(evt) {
|
|
+ case led_start: /* System startup */
|
|
+ at91_led_toggle(at91_leds_timer);
|
|
+ break;
|
|
+
|
|
+ case led_stop: /* System stop / suspend */
|
|
+ at91_led_toggle(at91_leds_timer);
|
|
+ break;
|
|
+
|
|
+#ifdef CONFIG_LEDS_TIMER
|
|
+ case led_timer: /* Every 50 timer ticks */
|
|
+ at91_led_toggle(at91_leds_timer);
|
|
+ break;
|
|
+#endif
|
|
+
|
|
+#ifdef CONFIG_LEDS_CPU
|
|
+ case led_idle_start: /* Entering idle state */
|
|
+ at91_led_toggle(at91_leds_timer);
|
|
+ break;
|
|
+
|
|
+ case led_idle_end: /* Exit idle state */
|
|
+ at91_led_toggle(at91_leds_timer);
|
|
+ break;
|
|
+#endif
|
|
+
|
|
+ default:
|
|
+ break;
|
|
+ }
|
|
+
|
|
+ local_irq_restore(flags);
|
|
+}
|
|
+
|
|
+
|
|
+static int __init leds_init(void)
|
|
+{
|
|
+ if (!at91_leds_timer || !at91_leds_cpu)
|
|
+ return -ENODEV;
|
|
+
|
|
+ leds_event = at91_leds_event;
|
|
+
|
|
+ leds_event(led_start);
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+__initcall(leds_init);
|