1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-15 19:50:02 +03:00
openwrt-xburst/target/linux/generic/patches-3.3/729-phy-tantos.patch
blogic 432fa085bd [generic] fix tantos patch properly
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32796 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-07-24 17:28:12 +00:00

22 lines
741 B
Diff

--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -206,3 +206,8 @@ endif # PHYLIB
config MICREL_KS8995MA
tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
depends on SPI
+
+config PSB6970_PHY
+ tristate "Lantiq XWAY Tantos (PSB6970) Ethernet switch"
+ select SWCONFIG
+ select ETHERNET_PACKET_MANGLE
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -28,6 +28,7 @@ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb
obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_MICREL_PHY) += micrel.o
+obj-$(CONFIG_PSB6970_PHY) += psb6970.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o