1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 04:16:27 +03:00
openwrt-xburst/package/hostapd/patches/007-add-nl80211-driver.patch
mb 67a3aa6b39 Add hostapd support for nl80211 (mac80211 stack)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10469 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-02-16 18:51:55 +00:00

18 lines
660 B
Diff

Index: hostapd-20071107_03ec0ec5cdb974d51a4a2a566bea4c4568138576/hostapd/Makefile
===================================================================
--- hostapd-20071107_03ec0ec5cdb974d51a4a2a566bea4c4568138576.orig/hostapd/Makefile 2007-11-16 05:08:24.000000000 +0100
+++ hostapd-20071107_03ec0ec5cdb974d51a4a2a566bea4c4568138576/hostapd/Makefile 2008-02-16 19:38:51.000000000 +0100
@@ -121,6 +121,12 @@ OBJS += driver_devicescape.o
LIBS += -lnl
endif
+ifdef CONFIG_DRIVER_NL80211
+CFLAGS += -DCONFIG_DRIVER_NL80211
+OBJS += driver_nl80211.o radiotap.o
+LIBS += -lnl
+endif
+
ifdef CONFIG_DRIVER_BSD
CFLAGS += -DCONFIG_DRIVER_BSD
OBJS += driver_bsd.o