1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-18 21:42:27 +03:00
openwrt-xburst/package/motion/patches/02-honor_cppflags.patch
nico dd25a83fa1 update motion package, add a patch to honor CPPFLAGS,
explicitely remove database support, add MD5SUMS, 
add dependency on libpthread in ipkg/control file,  
standardize.


git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3509 3c298f89-4303-0410-b956-a3cf2f4a3e73
2006-03-27 20:36:45 +00:00

21 lines
829 B
Diff

diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
--- motion-3.2.5.1-old/Makefile.in 2006-03-07 22:52:49.000000000 +0100
+++ motion-3.2.5.1-new/Makefile.in 2006-03-27 22:04:34.000000000 +0200
@@ -32,6 +32,7 @@
################################################################################
CFLAGS = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
-Dsysconfdir=\"$(sysconfdir)\"
+CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@
VIDEO_OBJ = @VIDEO@
@@ -115,7 +116,7 @@
################################################################################
$(DEPEND_FILE): *.h $(SRC)
@echo "Generating dependencies, please wait..."
- @$(CC) $(CFLAGS) -M $(SRC) > .tmp
+ @$(CC) $(CFLAGS) $(CPPFLAGS) -M $(SRC) > .tmp
@mv -f .tmp $(DEPEND_FILE)
@echo