mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 23:35:01 +02:00
c537863342
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13096 3c298f89-4303-0410-b956-a3cf2f4a3e73
17 lines
320 B
Diff
17 lines
320 B
Diff
--- a/scripts/get_arch.mk
|
|
+++ b/scripts/get_arch.mk
|
|
@@ -36,6 +36,13 @@ ifeq (,$(ARCH-y))
|
|
$(Cannot determine ARCH)
|
|
endif
|
|
|
|
+# Allow ARCH to be x86
|
|
+ifneq (,$(CONFIG_X86))
|
|
+ifeq (x86,$(ARCH))
|
|
+ARCH-y = $(ARCH)
|
|
+endif
|
|
+endif
|
|
+
|
|
# Don't allow ARCH to be overridden by a different value.
|
|
ifeq (,$(ARCH))
|
|
ARCH = $(ARCH-y)
|