1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-12-27 11:04:16 +02:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.24/004-extra_optimization.patch
juhosg 3d542aac84 [kernel] refresh generic 2.6.24 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11188 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-18 20:25:45 +00:00

15 lines
530 B
Diff

Index: linux-2.6.24.7/Makefile
===================================================================
--- linux-2.6.24.7.orig/Makefile
+++ linux-2.6.24.7/Makefile
@@ -527,6 +527,9 @@ KBUILD_CFLAGS += $(call cc-optio
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)