1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 11:12:25 +03:00
openwrt-xburst/target/linux/rb532/patches-2.6.24/110-korina_ethernet.patch
juhosg a358eec082 [rb532] refresh 2.6.24 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14452 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-02-08 19:18:19 +00:00

28 lines
774 B
Diff

--- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig
@@ -362,6 +362,13 @@ config AX88796_93CX6
help
Select this if your platform comes with an external 93CX6 eeprom.
+config KORINA
+ tristate "Korina Local Ethernet support"
+ depends on NET_ETHERNET && ( IDT_EB434 || MIKROTIK_RB500)
+ help
+ IDT RC32434 has one local ethernet port. Say Y here to enable it.
+ To compile this driver as a module, choose M here.
+
config MACE
tristate "MACE (Power Mac ethernet) support"
depends on PPC_PMAC && PPC32
--- a/drivers/net/Makefile
+++ b/drivers/net/Makefile
@@ -30,6 +30,8 @@ ucc_geth_driver-objs := ucc_geth.o ucc_g
#
obj-$(CONFIG_PLIP) += plip.o
+obj-$(CONFIG_KORINA) += korina.o
+
obj-$(CONFIG_ROADRUNNER) += rrunner.o
obj-$(CONFIG_HAPPYMEAL) += sunhme.o