1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 11:23:41 +03:00
openwrt-xburst/target/linux/rb532/patches-2.6.24/510-rb500_led.patch
juhosg a358eec082 [rb532] refresh 2.6.24 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14452 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-02-08 19:18:19 +00:00

26 lines
774 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -120,6 +120,12 @@ config LEDS_CM_X270
help
This option enables support for the CM-X270 LEDs.
+config LEDS_RB500
+ tristate "LED Support for RB5xx boards"
+ depends on LEDS_CLASS && MIKROTIK_RB500
+ help
+ This option enables support for the yellow user LED on RB5xx boards.
+
comment "LED Triggers"
config LEDS_TRIGGERS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -20,6 +20,7 @@ obj-$(CONFIG_LEDS_COBALT_QUBE) += leds-
obj-$(CONFIG_LEDS_COBALT_RAQ) += leds-cobalt-raq.o
obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
obj-$(CONFIG_LEDS_CM_X270) += leds-cm-x270.o
+obj-$(CONFIG_LEDS_RB500) += leds-rb500.o
# LED Triggers
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o