1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 12:06:49 +03:00
openwrt-xburst/target/linux/rdc/patches-2.6.24/004-rdc_fixes.patch
juhosg bff9e9b63b [rdc] refresh 2.6.24 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14451 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-02-08 19:17:40 +00:00

74 lines
2.2 KiB
Diff

--- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig
@@ -304,6 +304,17 @@ config X86_VSMP
supposed to run on these EM64T-based machines. Only choose this option
if you have one of these machines.
+config X86_RDC
+ bool "Support for RDC 3211 boards"
+ select GENERIC_GPIO
+ select LEDS_GPIO
+ select LEDS_CLASS
+ help
+ Support for RDC 3211 systems. Say 'Y' here if the kernel is
+ supposed to run on an IA-32 RDC R3211 system.
+ Only choose this option if you have such as system, otherwise you
+ should say N here.
+
endchoice
config SCHED_NO_NO_OMIT_FRAME_POINTER
--- a/arch/x86/kernel/reboot_fixups_32.c
+++ b/arch/x86/kernel/reboot_fixups_32.c
@@ -30,6 +30,17 @@ static void cs5536_warm_reset(struct pci
udelay(50); /* shouldn't get here but be safe and spin a while */
}
+static void r8610_reset(struct pci_dev *dev)
+{
+ int i;
+
+ outl(0x80003840,0xCF8);
+ i=inl(0xCFC);
+ i |= 0x1600;
+ outl(i,0xCFC);
+ outb(1,0x92);
+}
+
struct device_fixup {
unsigned int vendor;
unsigned int device;
@@ -40,6 +51,7 @@ static struct device_fixup fixups_table[
{ PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
{ PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
{ PCI_VENDOR_ID_NS, PCI_DEVICE_ID_NS_SC1100_BRIDGE, cs5530a_warm_reset },
+{ PCI_VENDOR_ID_RDC, PCI_DEVICE_ID_RDC_R6030, r8610_reset },
};
/*
--- a/arch/x86/Makefile_32
+++ b/arch/x86/Makefile_32
@@ -99,6 +99,11 @@ mflags-$(CONFIG_X86_ES7000) := -Iinclude
mcore-$(CONFIG_X86_ES7000) := arch/x86/mach-default
core-$(CONFIG_X86_ES7000) := arch/x86/mach-es7000/
+# RDC subarch support
+mflags-$(CONFIG_X86_RDC) := -Iinclude/asm-x86/mach-rdc
+mcore-$(CONFIG_X86_RDC) := arch/x86/mach-default
+core-$(CONFIG_X86_RDC) += arch/x86/mach-rdc/
+
# Xen paravirtualization support
core-$(CONFIG_XEN) += arch/x86/xen/
--- a/include/asm-x86/timex.h
+++ b/include/asm-x86/timex.h
@@ -7,6 +7,8 @@
#ifdef CONFIG_X86_ELAN
# define PIT_TICK_RATE 1189200 /* AMD Elan has different frequency! */
+#elif defined(CONFIG_X86_RDC)
+# define PIT_TICK_RATE 1041667 /* Underlying HZ for R8610 */
#else
# define PIT_TICK_RATE 1193182 /* Underlying HZ */
#endif