1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-19 22:44:11 +03:00
openwrt-xburst/target/linux/orion/patches/200-dt2_board_support.patch
rwhitby 0a75fedac4 orion: Added initial support for Freecom DT2. Thanks to Zintis.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14963 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-03-22 12:38:24 +00:00

27 lines
1.1 KiB
Diff

diff -ruN linux-2.6.28.5.orig/arch/arm/mach-orion5x/Kconfig linux-2.6.28.5/arch/arm/mach-orion5x/Kconfig
--- linux-2.6.28.5.orig/arch/arm/mach-orion5x/Kconfig 2009-02-21 00:41:27.000000000 +0200
+++ linux-2.6.28.5/arch/arm/mach-orion5x/Kconfig 2009-02-28 10:06:24.000000000 +0200
@@ -16,6 +16,13 @@
Say 'Y' here if you want your kernel to support the
Marvell Orion-NAS (88F5182) RD2
+config MACH_DT2
+ bool "Freecom DataTank Gateway"
+ select I2C_BOARDINFO
+ help
+ Say 'Y' here if you want your kernel to support the
+ Freecom DataTank Gateway
+
config MACH_KUROBOX_PRO
bool "KuroBox Pro"
select I2C_BOARDINFO
diff -ruN linux-2.6.28.5.orig/arch/arm/mach-orion5x/Makefile linux-2.6.28.5/arch/arm/mach-orion5x/Makefile
--- linux-2.6.28.5.orig/arch/arm/mach-orion5x/Makefile 2009-02-21 00:41:27.000000000 +0200
+++ linux-2.6.28.5/arch/arm/mach-orion5x/Makefile 2009-02-28 10:07:35.000000000 +0200
@@ -17,3 +17,4 @@
obj-$(CONFIG_MACH_RD88F5181L_GE) += rd88f5181l-ge-setup.o
obj-$(CONFIG_MACH_RD88F5181L_FXO) += rd88f5181l-fxo-setup.o
obj-$(CONFIG_MACH_RD88F6183AP_GE) += rd88f6183ap-ge-setup.o
+obj-$(CONFIG_MACH_DT2) += dt2-setup.o