mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-25 07:01:51 +02:00
30 lines
1.0 KiB
Diff
30 lines
1.0 KiB
Diff
--- a/drivers/misc/Kconfig
|
|
+++ b/drivers/misc/Kconfig
|
|
@@ -233,6 +233,17 @@ config ISL29003
|
|
This driver can also be built as a module. If so, the module
|
|
will be called isl29003.
|
|
|
|
+config JZ4740_ADC
|
|
+ tristate "Ingenic JZ4720/JZ4740 SoC ADC driver"
|
|
+ depends on SOC_JZ4740
|
|
+ help
|
|
+ If you say yes here you get support for the Ingenic JZ4720/JZ4740 SoC ADC
|
|
+ core. It is required for the JZ4720/JZ4740 battery and touchscreen driver
|
|
+ and is used to synchronize access to the adc core between those two.
|
|
+
|
|
+ This driver can also be build as a module. If so, the module will be
|
|
+ called jz4740-adc.
|
|
+
|
|
source "drivers/misc/c2port/Kconfig"
|
|
source "drivers/misc/eeprom/Kconfig"
|
|
source "drivers/misc/cb710/Kconfig"
|
|
--- a/drivers/misc/Makefile
|
|
+++ b/drivers/misc/Makefile
|
|
@@ -20,5 +20,6 @@ obj-$(CONFIG_SGI_GRU) += sgi-gru/
|
|
obj-$(CONFIG_HP_ILO) += hpilo.o
|
|
obj-$(CONFIG_ISL29003) += isl29003.o
|
|
obj-$(CONFIG_C2PORT) += c2port/
|
|
+obj-$(CONFIG_JZ4740_ADC) += jz4740-adc.o
|
|
obj-y += eeprom/
|
|
obj-y += cb710/
|