mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 00:29:41 +02:00
b577ffc8a5
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17084 3c298f89-4303-0410-b956-a3cf2f4a3e73
22 lines
436 B
Diff
22 lines
436 B
Diff
--- a/scripts/get_arch.mk
|
|
+++ b/scripts/get_arch.mk
|
|
@@ -36,11 +36,14 @@ ifeq (,$(ARCH-y))
|
|
$(Cannot determine ARCH)
|
|
endif
|
|
|
|
+# Allow ARCH to be x86
|
|
+ifneq (,$(CONFIG_X86))
|
|
+ifeq (x86,$(ARCH))
|
|
+ARCH-y = $(ARCH)
|
|
+endif
|
|
+endif
|
|
+
|
|
# Don't allow ARCH to be overridden by a different value.
|
|
ifeq (,$(ARCH))
|
|
ARCH = $(ARCH-y)
|
|
-else
|
|
-ifneq ($(ARCH),$(ARCH-y))
|
|
-$(error ARCH mismatch: supplied "$(ARCH)", determined "$(ARCH-y)")
|
|
-endif
|
|
endif
|