mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 13:04:04 +02:00
606dc5ad6f
- implement --add-dest and --add-arch commandline options, this allows to run entirely without configuration - tweak default config location patch to not require a config in offline root mode - rename --force-run-hooks option to --force-postinstall, its a more appropriate name - utilize new opkg commandline options in package-ipkg.mk and remove config file generation git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23032 3c298f89-4303-0410-b956-a3cf2f4a3e73
15 lines
309 B
Diff
15 lines
309 B
Diff
--- a/src/opkg-cl.c
|
|
+++ b/src/opkg-cl.c
|
|
@@ -172,7 +172,10 @@ args_parse(int argc, char *argv[])
|
|
printf("Confusion: getopt_long returned %d\n", c);
|
|
}
|
|
}
|
|
-
|
|
+
|
|
+ if(!conf->conf_file && !conf->offline_root)
|
|
+ conf->conf_file = xstrdup("/etc/opkg.conf");
|
|
+
|
|
if (parse_err)
|
|
return parse_err;
|
|
else
|