mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 00:29:41 +02:00
8d5c50e5f6
This updates uboot-envtools to the version which comes with U-Boot 2011.06. The important novelity is that fw_setenv now supports batch processing, which greatly improves sysupgrade of the ALL0258N as otherwise we would have to overwrite uboot-env up to 8x in a single firmware upgrade. Unfortunately, no newer version of the sources is available from Debian, so we got to take it from the u-boot source which is kinda ugly... Signed-off-by: Daniel Golle <dgolle@allnet.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28566 3c298f89-4303-0410-b956-a3cf2f4a3e73
46 lines
1.1 KiB
Diff
46 lines
1.1 KiB
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -21,37 +21,16 @@
|
|
# MA 02111-1307 USA
|
|
#
|
|
|
|
-include $(TOPDIR)/config.mk
|
|
-
|
|
-HOSTSRCS := $(obj)crc32.c fw_env.c fw_env_main.c
|
|
+SRCS := crc32.c fw_env.c fw_env_main.c
|
|
HEADERS := fw_env.h
|
|
|
|
-# Compile for a hosted environment on the target
|
|
-HOSTCPPFLAGS = -idirafter $(SRCTREE)/include \
|
|
- -idirafter $(OBJTREE)/include2 \
|
|
- -idirafter $(OBJTREE)/include \
|
|
- -DUSE_HOSTCC
|
|
-
|
|
-ifeq ($(MTD_VERSION),old)
|
|
-HOSTCPPFLAGS += -DMTD_OLD
|
|
-endif
|
|
+CPPFLAGS := -Wall $(CFLAGS)
|
|
|
|
all: $(obj)fw_printenv
|
|
|
|
# Some files complain if compiled with -pedantic, use HOSTCFLAGS_NOPED
|
|
-$(obj)fw_printenv: $(HOSTSRCS) $(HEADERS)
|
|
- $(HOSTCC) $(HOSTCFLAGS_NOPED) $(HOSTLDFLAGS) -o $@ $(HOSTSRCS)
|
|
+$(obj)fw_printenv: $(SRCS) $(HEADERS)
|
|
+ $(CC) $(CPPFLAGS) $(SRCS) -o $(obj)fw_printenv
|
|
|
|
clean:
|
|
- rm -f $(obj)fw_printenv $(obj)crc32.c
|
|
-
|
|
-$(obj)crc32.c:
|
|
- ln -s $(src)../../lib/crc32.c $(obj)crc32.c
|
|
-
|
|
-#########################################################################
|
|
-
|
|
-include $(TOPDIR)/rules.mk
|
|
-
|
|
-sinclude $(obj).depend
|
|
-
|
|
-#########################################################################
|
|
+ rm -f $(obj)fw_printenv
|