1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-20 19:42:25 +03:00
openwrt-xburst/target/linux/ar7/patches-2.6.24/110-flash.patch
matteo a16ea0db8f AR7 2.6.24 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10052 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-12-30 15:17:10 +00:00

44 lines
1.8 KiB
Diff

Index: linux-2.6.23-rc6/drivers/mtd/Kconfig
===================================================================
--- linux-2.6.23-rc6.orig/drivers/mtd/Kconfig 2007-09-21 16:23:59.000000000 +0800
+++ linux-2.6.23-rc6/drivers/mtd/Kconfig 2007-09-21 16:24:11.000000000 +0800
@@ -160,6 +160,12 @@
for your particular device. It won't happen automatically. The
'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
+config MTD_AR7_PARTS
+ tristate "TI AR7 partitioning support"
+ depends on MTD_PARTITIONS
+ ---help---
+ TI AR7 partitioning support
+
comment "User Modules And Translation Layers"
config MTD_CHAR
Index: linux-2.6.23-rc6/drivers/mtd/Makefile
===================================================================
--- linux-2.6.23-rc6.orig/drivers/mtd/Makefile 2007-09-21 16:23:51.000000000 +0800
+++ linux-2.6.23-rc6/drivers/mtd/Makefile 2007-09-21 16:24:11.000000000 +0800
@@ -11,6 +11,7 @@
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
# 'Users' - code which presents functionality to userspace.
obj-$(CONFIG_MTD_CHAR) += mtdchar.o
Index: linux-2.6.23-rc6/drivers/mtd/maps/physmap.c
===================================================================
--- linux-2.6.23-rc6.orig/drivers/mtd/maps/physmap.c 2007-09-21 16:23:51.000000000 +0800
+++ linux-2.6.23-rc6/drivers/mtd/maps/physmap.c 2007-09-21 16:24:11.000000000 +0800
@@ -74,7 +74,8 @@
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
#ifdef CONFIG_MTD_PARTITIONS
-static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
+static const char *part_probe_types[] = {"cmdlinepart", "RedBoot",
+ "ar7part", NULL };
#endif
static int physmap_flash_probe(struct platform_device *dev)