1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-19 10:58:59 +03:00
openwrt-xburst/target/linux/adm5120-2.6/patches/004-adm5120_uart.patch
juhosg 8cb689db3a [adm5120] restore right patches for 2.6.21.5
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7800 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-06-30 15:23:06 +00:00

54 lines
1.8 KiB
Diff

Index: linux-2.6.21.1/drivers/serial/Makefile
===================================================================
--- linux-2.6.21.1.orig/drivers/serial/Makefile
+++ linux-2.6.21.1/drivers/serial/Makefile
@@ -21,6 +21,7 @@ obj-$(CONFIG_SERIAL_8250_EXAR_ST16C554)
obj-$(CONFIG_SERIAL_8250_HUB6) += 8250_hub6.o
obj-$(CONFIG_SERIAL_8250_MCA) += 8250_mca.o
obj-$(CONFIG_SERIAL_8250_AU1X00) += 8250_au1x00.o
+obj-$(CONFIG_SERIAL_ADM5120) += adm5120_uart.o
obj-$(CONFIG_SERIAL_AMBA_PL010) += amba-pl010.o
obj-$(CONFIG_SERIAL_AMBA_PL011) += amba-pl011.o
obj-$(CONFIG_SERIAL_CLPS711X) += clps711x.o
Index: linux-2.6.21.1/include/linux/serial_core.h
===================================================================
--- linux-2.6.21.1.orig/include/linux/serial_core.h
+++ linux-2.6.21.1/include/linux/serial_core.h
@@ -135,6 +135,9 @@
/* Xilinx uartlite */
#define PORT_UARTLITE 74
+/* ADMtek ADM5120 SoC */
+#define PORT_ADM5120 68
+
#ifdef __KERNEL__
#include <linux/compiler.h>
Index: linux-2.6.21.1/drivers/serial/Kconfig
===================================================================
--- linux-2.6.21.1.orig/drivers/serial/Kconfig
+++ linux-2.6.21.1/drivers/serial/Kconfig
@@ -256,6 +256,22 @@ config SERIAL_8250_AU1X00
comment "Non-8250 serial port support"
+config SERIAL_ADM5120
+ bool "ADM5120 serial port support"
+ depends on MIPS_ADM5120
+ select SERIAL_CORE
+ select SERIAL_CORE_CONSOLE
+ help
+ Driver for the on chip UARTs on the ADM5120 SoC
+
+config ADM5120_NR_UARTS
+ int "Maximum number of ADM5120 serial ports"
+ depends on SERIAL_ADM5120
+ default "2"
+ ---help---
+ Set this to the number of serial ports you want the driver to
+ support.
+
config SERIAL_AMBA_PL010
tristate "ARM AMBA PL010 serial port support"
depends on ARM_AMBA && (BROKEN || !ARCH_VERSATILE)