1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-19 01:47:07 +03:00
openwrt-xburst/target/linux/atheros/patches-2.6.25/130-ar2313_ethernet.patch
juhosg 7331aafb13 [atheros] add .25 patches (kernel boots fine on LS2, LS5, FON2200 and on WRT55AG v2)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11016 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-03 05:43:29 +00:00

30 lines
1.1 KiB
Diff

Index: linux-2.6.25.1/drivers/net/Kconfig
===================================================================
--- linux-2.6.25.1.orig/drivers/net/Kconfig
+++ linux-2.6.25.1/drivers/net/Kconfig
@@ -367,6 +367,12 @@ config AX88796_93CX6
help
Select this if your platform comes with an external 93CX6 eeprom.
+config AR2313
+ tristate "AR2313 Ethernet support"
+ depends on NET_ETHERNET && ATHEROS
+ help
+ Support for the AR231x/531x ethernet controller
+
config MACE
tristate "MACE (Power Mac ethernet) support"
depends on PPC_PMAC && PPC32
Index: linux-2.6.25.1/drivers/net/Makefile
===================================================================
--- linux-2.6.25.1.orig/drivers/net/Makefile
+++ linux-2.6.25.1/drivers/net/Makefile
@@ -194,6 +194,7 @@ obj-$(CONFIG_MVME147_NET) += mvme147.o 7
obj-$(CONFIG_EQUALIZER) += eql.o
obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
+obj-$(CONFIG_AR2313) += ar2313/
obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
obj-$(CONFIG_DECLANCE) += declance.o