1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 12:18:04 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.23/004-adm5120_nand.patch
juhosg 549710c306 [adm5120] prepare for 2.6.23
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9258 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-10-11 07:45:02 +00:00

34 lines
1.2 KiB
Diff

Index: linux-2.6.23/drivers/mtd/nand/Kconfig
===================================================================
--- linux-2.6.23.orig/drivers/mtd/nand/Kconfig
+++ linux-2.6.23/drivers/mtd/nand/Kconfig
@@ -81,6 +81,16 @@ config MTD_NAND_TS7250
help
Support for NAND flash on Technologic Systems TS-7250 platform.
+config MTD_NAND_ADM5120
+ tristate "ADM5120 NAND support"
+ depends on MTD_NAND && MIPS_ADM5120
+ help
+ This enables the driver for the ADM5120 SoC built-in
+ NAND flash interface.
+
+ No board specific support is done by this driver, each board
+ must advertise a platform_device for the driver to attach.
+
config MTD_NAND_IDS
tristate
Index: linux-2.6.23/drivers/mtd/nand/Makefile
===================================================================
--- linux-2.6.23.orig/drivers/mtd/nand/Makefile
+++ linux-2.6.23/drivers/mtd/nand/Makefile
@@ -10,6 +10,7 @@ obj-$(CONFIG_MTD_NAND_CAFE) += cafe_nan
obj-$(CONFIG_MTD_NAND_SPIA) += spia.o
obj-$(CONFIG_MTD_NAND_AMS_DELTA) += ams-delta.o
obj-$(CONFIG_MTD_NAND_TOTO) += toto.o
+obj-$(CONFIG_MTD_NAND_ADM5120) += adm5120-nand.o
obj-$(CONFIG_MTD_NAND_AUTCPU12) += autcpu12.o
obj-$(CONFIG_MTD_NAND_EDB7312) += edb7312.o
obj-$(CONFIG_MTD_NAND_AU1550) += au1550nd.o