1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 12:18:04 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.23/006-adm5120_leds.patch
juhosg 572b00c7f4 [adm5120] switch to 2.6.23
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9260 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-10-11 09:11:56 +00:00

39 lines
1.3 KiB
Diff

Index: linux-2.6.23/drivers/leds/Kconfig
===================================================================
--- linux-2.6.23.orig/drivers/leds/Kconfig
+++ linux-2.6.23/drivers/leds/Kconfig
@@ -18,6 +18,21 @@ config LEDS_CLASS
comment "LED drivers"
+config LEDS_ADM5120
+ tristate "LED Support for ADM5120 GPIO LEDs"
+ depends on LEDS_GPIO && MIPS_ADM5120
+ help
+ This option enables support for LEDs connected to GPIO lines
+ on ADM5120 SoC based platforms.
+
+config LEDS_ADM5120_EXPERIMENTAL
+ bool "Enable ADM5120 LEDs experimental code"
+ depends on LEDS_ADM5120
+
+config LEDS_ADM5120_DIAG
+ bool "Enable ADM5120 LEDs diagnostic mode"
+ depends on LEDS_ADM5120
+
config LEDS_CORGI
tristate "LED Support for the Sharp SL-C7x0 series"
depends on LEDS_CLASS && PXA_SHARP_C7xx
Index: linux-2.6.23/drivers/leds/Makefile
===================================================================
--- linux-2.6.23.orig/drivers/leds/Makefile
+++ linux-2.6.23/drivers/leds/Makefile
@@ -5,6 +5,7 @@ obj-$(CONFIG_LEDS_CLASS) += led-class.o
obj-$(CONFIG_LEDS_TRIGGERS) += led-triggers.o
# LED Platform Drivers
+obj-$(CONFIG_LEDS_ADM5120) += leds-adm5120.o
obj-$(CONFIG_LEDS_CORGI) += leds-corgi.o
obj-$(CONFIG_LEDS_LOCOMO) += leds-locomo.o
obj-$(CONFIG_LEDS_SPITZ) += leds-spitz.o