1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 12:18:04 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.23/008-adm5120_uart.patch
juhosg 549710c306 [adm5120] prepare for 2.6.23
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9258 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-10-11 07:45:02 +00:00

54 lines
1.8 KiB
Diff

Index: linux-2.6.23/drivers/serial/Makefile
===================================================================
--- linux-2.6.23.orig/drivers/serial/Makefile
+++ linux-2.6.23/drivers/serial/Makefile
@@ -21,6 +21,7 @@ obj-$(CONFIG_SERIAL_8250_EXAR_ST16C554)
obj-$(CONFIG_SERIAL_8250_HUB6) += 8250_hub6.o
obj-$(CONFIG_SERIAL_8250_MCA) += 8250_mca.o
obj-$(CONFIG_SERIAL_8250_AU1X00) += 8250_au1x00.o
+obj-$(CONFIG_SERIAL_ADM5120) += adm5120_uart.o
obj-$(CONFIG_SERIAL_AMBA_PL010) += amba-pl010.o
obj-$(CONFIG_SERIAL_AMBA_PL011) += amba-pl011.o
obj-$(CONFIG_SERIAL_CLPS711X) += clps711x.o
Index: linux-2.6.23/include/linux/serial_core.h
===================================================================
--- linux-2.6.23.orig/include/linux/serial_core.h
+++ linux-2.6.23/include/linux/serial_core.h
@@ -147,6 +147,9 @@
#define PORT_SB1250_DUART 77
+/* ADMtek ADM5120 SoC */
+#define PORT_ADM5120 77
+
#ifdef __KERNEL__
#include <linux/compiler.h>
Index: linux-2.6.23/drivers/serial/Kconfig
===================================================================
--- linux-2.6.23.orig/drivers/serial/Kconfig
+++ linux-2.6.23/drivers/serial/Kconfig
@@ -280,6 +280,22 @@ config SERIAL_8250_RM9K
comment "Non-8250 serial port support"
+config SERIAL_ADM5120
+ bool "ADM5120 serial port support"
+ depends on MIPS_ADM5120
+ select SERIAL_CORE
+ select SERIAL_CORE_CONSOLE
+ help
+ Driver for the on chip UARTs on the ADM5120 SoC
+
+config ADM5120_NR_UARTS
+ int "Maximum number of ADM5120 serial ports"
+ depends on SERIAL_ADM5120
+ default "2"
+ ---help---
+ Set this to the number of serial ports you want the driver to
+ support.
+
config SERIAL_AMBA_PL010
tristate "ARM AMBA PL010 serial port support"
depends on ARM_AMBA && (BROKEN || !ARCH_VERSATILE)