1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 12:18:04 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.23/009-adm5120_leds_switch_trigger.patch
juhosg 07c2f61f37 [adm5120] add LEDs trigger for switch port states, thanks to Bernhard Held (closes: #2153)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9362 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-10-20 07:45:08 +00:00

27 lines
1.0 KiB
Diff

Index: linux-2.6.23/drivers/leds/Kconfig
===================================================================
--- linux-2.6.23.orig/drivers/leds/Kconfig
+++ linux-2.6.23/drivers/leds/Kconfig
@@ -152,4 +152,12 @@ config LEDS_TRIGGER_MORSE
tristate "LED Morse Trigger"
depends on LEDS_TRIGGERS
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
+ depends on LEDS_TRIGGERS && LEDS_ADM5120
+ help
+ This allows LEDs to be controlled by the port states of
+ the ADM5120 built-in Ethernet Switch
+ If unsure, say N.
+
endif # NEW_LEDS
Index: linux-2.6.23/drivers/leds/Makefile
===================================================================
--- linux-2.6.23.orig/drivers/leds/Makefile
+++ linux-2.6.23/drivers/leds/Makefile
@@ -24,3 +24,4 @@ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledt
obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o