1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 12:18:04 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.23/120-cf.patch
florian 3fb6c53e6d The RB513 CF driver is now a module, enable it by default for the RB1xx profile.
Fix the membase of the CF driver.


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9416 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-10-23 10:46:19 +00:00

44 lines
1.5 KiB
Diff

Index: linux-2.6.23/drivers/block/Kconfig
===================================================================
--- linux-2.6.23/drivers/block/Kconfig 2007-10-09 22:31:38.000000000 +0200
+++ linux-2.6.23.new/drivers/block/Kconfig 2007-10-22 18:07:49.000000000 +0200
@@ -65,6 +65,14 @@
To compile this driver as a module, choose M here: the
module will be called z2ram.
+config BLK_DEV_CF_MIPS
+ tristate "CF slot of RB153 board"
+ depends on MIPS_ADM5120
+ default y
+ help
+ The Routerboard 153 has a CF slot on it. Enable the special block
+ device driver for it.
+
config BLK_DEV_XD
tristate "XT hard disk support"
depends on ISA && ISA_DMA_API
Index: linux-2.6.23/drivers/block/Makefile
===================================================================
--- linux-2.6.23/drivers/block/Makefile 2007-10-09 22:31:38.000000000 +0200
+++ linux-2.6.23.new/drivers/block/Makefile.new 2007-10-22 18:08:15.000000000 +0200
@@ -7,6 +7,7 @@
obj-$(CONFIG_MAC_FLOPPY) += swim3.o
obj-$(CONFIG_BLK_DEV_FD) += floppy.o
+obj-$(CONFIG_BLK_DEV_CF_MIPS) += rb1xx/
obj-$(CONFIG_AMIGA_FLOPPY) += amiflop.o
obj-$(CONFIG_PS3_DISK) += ps3disk.o
obj-$(CONFIG_ATARI_FLOPPY) += ataflop.o
diff --git a/fs/partitions/check.c b/fs/partitions/check.c
index 722e12e..60af038 100644
--- a/fs/partitions/check.c
+++ b/fs/partitions/check.c
@@ -526,6 +526,7 @@ exit:
kobject_uevent(&p->kobj, KOBJ_ADD);
}
}
+EXPORT_SYMBOL(register_disk);
int rescan_partitions(struct gendisk *disk, struct block_device *bdev)
{