mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 22:25:20 +02:00
ed6be451a0
Also make linux identify itself properly as 3.0, not 3.0.0. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27191 3c298f89-4303-0410-b956-a3cf2f4a3e73
28 lines
835 B
Diff
28 lines
835 B
Diff
--- a/drivers/char/Kconfig
|
|
+++ b/drivers/char/Kconfig
|
|
@@ -511,6 +511,14 @@ config NSC_GPIO
|
|
pc8736x_gpio drivers. If those drivers are built as
|
|
modules, this one will be too, named nsc_gpio
|
|
|
|
+config GPIO_DEVICE
|
|
+ tristate "GPIO device support"
|
|
+ depends on GENERIC_GPIO
|
|
+ help
|
|
+ Say Y to enable Linux GPIO device support. This allows control of
|
|
+ GPIO pins using a character device
|
|
+
|
|
+
|
|
config RAW_DRIVER
|
|
tristate "RAW driver (/dev/raw/rawN)"
|
|
depends on BLOCK
|
|
--- a/drivers/char/Makefile
|
|
+++ b/drivers/char/Makefile
|
|
@@ -47,6 +47,7 @@ obj-$(CONFIG_NWFLASH) += nwflash.o
|
|
obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
|
|
obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
|
|
obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
|
|
+obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
|
|
obj-$(CONFIG_GPIO_TB0219) += tb0219.o
|
|
obj-$(CONFIG_TELCLOCK) += tlclk.o
|
|
|