mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 13:58:27 +02:00
7c90f3b2b4
This target currently only supports Moschip's MCS8140 SoC, but support for other chips in the same family (MCS8142, MCS8144) will be easy to add. Target support is entirely using Device Tree for probing peripherals. Drivers support include: - PCI - USB 1 & 2 - watchdog - random number generator - UART - timer - internal Ethernet PHY - Ethernet MAC core Support for the following boards is included using Device Tree - Devolo dLAN USB Extender - Tigal RBT-832 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32462 3c298f89-4303-0410-b956-a3cf2f4a3e73
21 lines
657 B
Diff
21 lines
657 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -135,6 +135,10 @@ config MICREL_PHY
|
|
---help---
|
|
Currently has a driver for the KSZ8041
|
|
|
|
+config MCS814X_PHY
|
|
+ tristate "Driver for the Moschip MCS814x internal PHY"
|
|
+ depends on ARCH_MCS814X
|
|
+
|
|
config FIXED_PHY
|
|
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
|
|
depends on PHYLIB=y
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -38,3 +38,4 @@ obj-$(CONFIG_STE10XP) += ste10Xp.o
|
|
obj-$(CONFIG_MICREL_PHY) += micrel.o
|
|
obj-$(CONFIG_MDIO_OCTEON) += mdio-octeon.o
|
|
obj-$(CONFIG_MICREL_KS8995MA) += spi_ks8995.o
|
|
+obj-$(CONFIG_MCS814X_PHY) += mcs814x.o
|