mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 01:02:49 +02:00
5d24c5688a
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16611 3c298f89-4303-0410-b956-a3cf2f4a3e73
38 lines
1.6 KiB
Diff
38 lines
1.6 KiB
Diff
--- a/sound/soc/s3c24xx/Kconfig
|
|
+++ b/sound/soc/s3c24xx/Kconfig
|
|
@@ -42,10 +42,20 @@ config SND_S3C24XX_SOC_JIVE_WM8750
|
|
tristate "SoC I2S Audio support for Jive"
|
|
depends on SND_S3C24XX_SOC && MACH_JIVE
|
|
select SND_SOC_WM8750
|
|
+ select SND_SOC_WM8750_SPI
|
|
select SND_S3C2412_SOC_I2S
|
|
help
|
|
Sat Y if you want to add support for SoC audio on the Jive.
|
|
|
|
+config SND_S3C24XX_SOC_NEO1973_GTA02_WM8753
|
|
+ tristate "SoC I2S Audio support for Openmoko Freerunner - WM8753"
|
|
+ depends on SND_S3C24XX_SOC && MACH_NEO1973_GTA02
|
|
+ select SND_S3C24XX_SOC_I2S
|
|
+ select SND_SOC_WM8753
|
|
+ help
|
|
+ Say Y if you want to add support for SoC audio on Openmoko Freerunner
|
|
+ with the WM8753 codec
|
|
+
|
|
config SND_S3C24XX_SOC_SMDK2443_WM9710
|
|
tristate "SoC AC97 Audio support for SMDK2443 - WM9710"
|
|
depends on SND_S3C24XX_SOC && MACH_SMDK2443
|
|
--- a/sound/soc/s3c24xx/Makefile
|
|
+++ b/sound/soc/s3c24xx/Makefile
|
|
@@ -19,9 +19,11 @@ snd-soc-neo1973-wm8753-objs := neo1973_w
|
|
snd-soc-smdk2443-wm9710-objs := smdk2443_wm9710.o
|
|
snd-soc-ln2440sbc-alc650-objs := ln2440sbc_alc650.o
|
|
snd-soc-s3c24xx-uda134x-objs := s3c24xx_uda134x.o
|
|
+snd-soc-neo1973-gta02-wm8753-objs := gta02_wm8753.o
|
|
|
|
obj-$(CONFIG_SND_S3C24XX_SOC_JIVE_WM8750) += snd-soc-jive-wm8750.o
|
|
obj-$(CONFIG_SND_S3C24XX_SOC_NEO1973_WM8753) += snd-soc-neo1973-wm8753.o
|
|
obj-$(CONFIG_SND_S3C24XX_SOC_SMDK2443_WM9710) += snd-soc-smdk2443-wm9710.o
|
|
obj-$(CONFIG_SND_S3C24XX_SOC_LN2440SBC_ALC650) += snd-soc-ln2440sbc-alc650.o
|
|
obj-$(CONFIG_SND_S3C24XX_SOC_S3C24XX_UDA134X) += snd-soc-s3c24xx-uda134x.o
|
|
+obj-$(CONFIG_SND_S3C24XX_SOC_NEO1973_GTA02_WM8753) += snd-soc-neo1973-gta02-wm8753.o
|