1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-16 08:26:36 +03:00
openwrt-xburst/target/linux/ar7/patches-3.6/120-gpio_chrdev.patch
florian e58dc6f93a [ar7] add support for Linux 3.6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34154 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-11-11 18:41:09 +00:00

29 lines
876 B
Diff

--- a/drivers/char/Kconfig
+++ b/drivers/char/Kconfig
@@ -463,6 +463,15 @@ config MWAVE
To compile this driver as a module, choose M here: the
module will be called mwave.
+config AR7_GPIO
+ tristate "TI AR7 GPIO Support"
+ depends on AR7
+ help
+ Give userspace access to the GPIO pins on the Texas Instruments AR7
+ processors.
+
+ If compiled as a module, it will be called ar7_gpio.
+
config SCx200_GPIO
tristate "NatSemi SCx200 GPIO Support"
depends on SCx200
--- a/drivers/char/Makefile
+++ b/drivers/char/Makefile
@@ -43,6 +43,7 @@ obj-$(CONFIG_HW_RANDOM) += hw_random/
obj-$(CONFIG_PPDEV) += ppdev.o
obj-$(CONFIG_NWBUTTON) += nwbutton.o
obj-$(CONFIG_NWFLASH) += nwflash.o
+obj-$(CONFIG_AR7_GPIO) += ar7_gpio.o
obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o