1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 16:19:53 +03:00
openwrt-xburst/package/hostapd/patches/001-cross_compile_fix.patch
nbd b5cb1795de refresh all package patches in the buildroot using quilt
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7490 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-06-04 11:25:53 +00:00

37 lines
1.1 KiB
Diff

Common subdirectories: hostapd-0.5.2/logwatch and hostapd-0.5.2.new/logwatch
Index: hostapd-0.5.7/Makefile
===================================================================
--- hostapd-0.5.7.orig/Makefile 2007-06-04 13:22:31.790022464 +0200
+++ hostapd-0.5.7/Makefile 2007-06-04 13:22:31.856012432 +0200
@@ -2,7 +2,7 @@
DIR_WPA_SUPPLICANT=.
ifndef CFLAGS
-CFLAGS = -MMD -O2 -Wall -g
+CFLAGS = -MMD $(OPTFLAGS) $(CPPFLAGS)
endif
# define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
@@ -336,7 +336,7 @@
for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
hostapd: $(OBJS)
- $(CC) -o hostapd $(OBJS) $(LIBS)
+ $(CC) -o hostapd $(OBJS) $(LDFLAGS) $(LIBS)
driver_conf.c: Makefile .config
rm -f driver_conf.c
@@ -400,10 +400,10 @@
endif
nt_password_hash: $(NOBJS)
- $(CC) -o nt_password_hash $(NOBJS) $(LIBS_n)
+ $(CC) -o nt_password_hash $(NOBJS) $(LDFLAGS) $(LIBS_n)
hlr_auc_gw: $(HOBJS)
- $(CC) -o hlr_auc_gw $(HOBJS) $(LIBS_h)
+ $(CC) -o hlr_auc_gw $(HOBJS) $(LDFLAGS) $(LIBS_h)
clean:
rm -f core *~ *.o hostapd hostapd_cli nt_password_hash hlr_auc_gw