mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:06:15 +02:00
321367ef07
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20477 3c298f89-4303-0410-b956-a3cf2f4a3e73
21 lines
643 B
Diff
21 lines
643 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -113,7 +113,7 @@ LD = $(CROSS_COMPILE)gcc
|
|
AR = $(CROSS_COMPILE)ar
|
|
RANLIB = $(CROSS_COMPILE)ranlib
|
|
|
|
-CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
|
|
+CFLAGS = -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
|
|
WARNINGS = -Wstrict-prototypes -Wsign-compare -Wshadow \
|
|
-Wchar-subscripts -Wmissing-declarations -Wnested-externs \
|
|
-Wpointer-arith -Wcast-align -Wsign-compare -Wmissing-prototypes
|
|
@@ -130,7 +130,7 @@ endif
|
|
|
|
# if DEBUG is enabled, then we do not strip
|
|
ifeq ($(strip $(DEBUG)),true)
|
|
- CFLAGS += -DDEBUG
|
|
+ CFLAGS += -g -DDEBUG
|
|
endif
|
|
|
|
ifeq ($(strip $(USE_GCOV)),true)
|