mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 13:16:14 +02:00
4648720ba6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3549 3c298f89-4303-0410-b956-a3cf2f4a3e73
154 lines
4.2 KiB
Diff
154 lines
4.2 KiB
Diff
diff -urN openssl-0.9.8a/Makefile openssl-0.9.8a.new/Makefile
|
|
--- openssl-0.9.8a/Makefile 2005-10-11 12:21:48.000000000 +0200
|
|
+++ openssl-0.9.8a.new/Makefile 2006-03-29 15:23:28.107586680 +0200
|
|
@@ -102,7 +102,7 @@
|
|
KRB5_INCLUDES=
|
|
LIBKRB5=
|
|
|
|
-DIRS= crypto ssl engines apps test tools
|
|
+DIRS= crypto ssl engines apps tools
|
|
SHLIBDIRS= crypto ssl
|
|
|
|
# dirs in crypto to build
|
|
@@ -119,7 +119,7 @@
|
|
|
|
# tests to perform. "alltests" is a special word indicating that all tests
|
|
# should be performed.
|
|
-TESTS = alltests
|
|
+TESTS =
|
|
|
|
MAKEFILE= Makefile
|
|
|
|
@@ -131,7 +131,7 @@
|
|
|
|
TOP= .
|
|
ONEDIRS=out tmp
|
|
-EDIRS= times doc bugs util include certs ms shlib mt demos perl sf dep VMS
|
|
+EDIRS= times bugs util include certs ms shlib mt demos perl sf dep VMS
|
|
WDIRS= windows
|
|
LIBS= libcrypto.a libssl.a
|
|
SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
|
|
@@ -204,7 +204,7 @@
|
|
@[ -n "$(THIS)" ] && $(CLEARENV) && $(MAKE) $(THIS) -e $(BUILDENV)
|
|
|
|
sub_all: build_all
|
|
-build_all: build_libs build_apps build_tests build_tools
|
|
+build_all: build_libs build_apps build_tools
|
|
|
|
build_libs: build_crypto build_ssl build_engines
|
|
|
|
@@ -454,7 +454,7 @@
|
|
dist_pem_h:
|
|
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
|
|
|
|
-install: all install_docs install_sw
|
|
+install: all install_sw
|
|
|
|
install_sw:
|
|
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
|
|
diff -urN openssl-0.9.8a/Makefile.bak openssl-0.9.8a.new/Makefile.bak
|
|
--- openssl-0.9.8a/Makefile.bak 2005-10-11 12:21:44.000000000 +0200
|
|
+++ openssl-0.9.8a.new/Makefile.bak 2006-03-29 15:28:48.660855176 +0200
|
|
@@ -102,7 +102,7 @@
|
|
KRB5_INCLUDES=
|
|
LIBKRB5=
|
|
|
|
-DIRS= crypto ssl engines apps test tools
|
|
+DIRS= crypto ssl engines apps tools
|
|
SHLIBDIRS= crypto ssl
|
|
|
|
# dirs in crypto to build
|
|
@@ -119,7 +119,7 @@
|
|
|
|
# tests to perform. "alltests" is a special word indicating that all tests
|
|
# should be performed.
|
|
-TESTS = alltests
|
|
+TESTS =
|
|
|
|
MAKEFILE= Makefile
|
|
|
|
@@ -131,7 +131,7 @@
|
|
|
|
TOP= .
|
|
ONEDIRS=out tmp
|
|
-EDIRS= times doc bugs util include certs ms shlib mt demos perl sf dep VMS
|
|
+EDIRS= times bugs util include certs ms shlib mt demos perl sf dep VMS
|
|
WDIRS= windows
|
|
LIBS= libcrypto.a libssl.a
|
|
SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
|
|
@@ -204,7 +204,7 @@
|
|
@[ -n "$(THIS)" ] && $(CLEARENV) && $(MAKE) $(THIS) -e $(BUILDENV)
|
|
|
|
sub_all: build_all
|
|
-build_all: build_libs build_apps build_tests build_tools
|
|
+build_all: build_libs build_apps build_tools
|
|
|
|
build_libs: build_crypto build_ssl build_engines
|
|
|
|
@@ -221,7 +221,7 @@
|
|
build_tools:
|
|
@dir=tools; target=all; $(BUILD_CMD)
|
|
|
|
-all_testapps: build_libs build_testapps
|
|
+all_testapps: build_libs
|
|
build_testapps:
|
|
@dir=crypto; target=testapps; $(BUILD_CMD)
|
|
|
|
@@ -454,7 +454,7 @@
|
|
dist_pem_h:
|
|
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
|
|
|
|
-install: all install_docs install_sw
|
|
+install: all install_sw
|
|
|
|
install_sw:
|
|
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
|
|
diff -urN openssl-0.9.8a/Makefile.org openssl-0.9.8a.new/Makefile.org
|
|
--- openssl-0.9.8a/Makefile.org 2006-03-29 14:59:41.941396896 +0200
|
|
+++ openssl-0.9.8a.new/Makefile.org 2006-03-29 15:29:46.126119128 +0200
|
|
@@ -117,7 +117,7 @@
|
|
|
|
# tests to perform. "alltests" is a special word indicating that all tests
|
|
# should be performed.
|
|
-TESTS = alltests
|
|
+TESTS =
|
|
|
|
MAKEFILE= Makefile
|
|
|
|
@@ -129,7 +129,7 @@
|
|
|
|
TOP= .
|
|
ONEDIRS=out tmp
|
|
-EDIRS= times doc bugs util include certs ms shlib mt demos perl sf dep VMS
|
|
+EDIRS= times bugs util include certs ms shlib mt demos perl sf dep VMS
|
|
WDIRS= windows
|
|
LIBS= libcrypto.a libssl.a
|
|
SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
|
|
@@ -202,7 +202,7 @@
|
|
@[ -n "$(THIS)" ] && $(CLEARENV) && $(MAKE) $(THIS) -e $(BUILDENV)
|
|
|
|
sub_all: build_all
|
|
-build_all: build_libs build_apps build_tests build_tools
|
|
+build_all: build_libs build_apps build_tools
|
|
|
|
build_libs: build_crypto build_ssl build_engines
|
|
|
|
@@ -219,7 +219,7 @@
|
|
build_tools:
|
|
@dir=tools; target=all; $(BUILD_CMD)
|
|
|
|
-all_testapps: build_libs build_testapps
|
|
+all_testapps: build_libs
|
|
build_testapps:
|
|
@dir=crypto; target=testapps; $(BUILD_CMD)
|
|
|
|
@@ -452,7 +452,7 @@
|
|
dist_pem_h:
|
|
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
|
|
|
|
-install: all install_docs install_sw
|
|
+install: all install_sw
|
|
|
|
install_sw:
|
|
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
|