1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-19 13:03:41 +03:00
openwrt-xburst/package/libtool/patches/100-libdir_path.patch
lars e89fb9a631 [package] libtool: Don't use the libdir path found in .la files.
Fixes the build of various packages.


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19422 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-01-30 18:08:45 +00:00

50 lines
1.8 KiB
Diff

--- a/Makefile.in
+++ b/Makefile.in
@@ -789,6 +789,7 @@ $(srcdir)/ltmain.sh: $(srcdir)/ltmain.in
-rm -f ltmain.shT
date=`$(SHELL) $(srcdir)/mkstamp < $(srcdir)/ChangeLog` && \
sed -e 's/@''PACKAGE@/@PACKAGE@/' -e 's/@''VERSION@/@VERSION@/' \
+ -e 's#@''GLOBAL_LIBDIR@#$(GLOBAL_LIBDIR)#' \
-e "s%@""TIMESTAMP@%$$date%" $(srcdir)/ltmain.in > ltmain.shT
mv -f ltmain.shT $@ || \
(rm -f $@ && cp ltmain.shT $@ && rm -f ltmain.shT)
--- a/ltmain.in
+++ b/ltmain.in
@@ -2827,7 +2827,7 @@ EOF
fi
else
# We cannot seem to hardcode it, guess we'll fake it.
- add_dir="-L$libdir"
+ add_dir="-L@GLOBAL_LIBDIR@"
# Try looking first in the location we're being installed to.
if test -n "$inst_prefix_dir"; then
case $libdir in
@@ -5669,7 +5669,7 @@ fi\
$echo "$modename: \`$deplib' is not a valid libtool archive" 1>&2
exit $EXIT_FAILURE
fi
- newdependency_libs="$newdependency_libs $libdir/$name"
+ newdependency_libs="$newdependency_libs @GLOBAL_LIBDIR@/$name"
;;
*) newdependency_libs="$newdependency_libs $deplib" ;;
esac
@@ -5694,7 +5694,7 @@ fi\
$echo "$modename: \`$lib' is not a valid libtool archive" 1>&2
exit $EXIT_FAILURE
fi
- newdlprefiles="$newdlprefiles $libdir/$name"
+ newdlprefiles="$newdlprefiles @GLOBAL_LIBDIR@/$name"
done
dlprefiles="$newdlprefiles"
else
--- a/Makefile.am
+++ b/Makefile.am
@@ -67,6 +67,7 @@ $(srcdir)/ltmain.sh: $(srcdir)/ltmain.in
-rm -f ltmain.shT
date=`$(SHELL) $(srcdir)/mkstamp < $(srcdir)/ChangeLog` && \
sed -e 's/@''PACKAGE@/@PACKAGE@/' -e 's/@''VERSION@/@VERSION@/' \
+ -e 's#@''GLOBAL_LIBDIR@#$(GLOBAL_LIBDIR)#' \
-e "s%@""TIMESTAMP@%$$date%" $(srcdir)/ltmain.in > ltmain.shT
mv -f ltmain.shT $@ || \
(rm -f $@ && cp ltmain.shT $@ && rm -f ltmain.shT)