mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-12-27 12:39:53 +02:00
78fcab66df
Conflicts: feeds.conf.default package/base-files/Makefile package/block-extroot/Makefile package/block-mount/Makefile package/busybox/Makefile package/busybox/config/util-linux/Config.in package/dnsmasq/Makefile package/dnsmasq/files/dnsmasq.init package/uhttpd/Makefile target/linux/adm5120/image/Makefile target/linux/amazon/image/Makefile target/linux/ar71xx/config-2.6.33 target/linux/ar71xx/config-2.6.34 target/linux/at91/image/Makefile target/linux/atheros/patches-2.6.33/220-enet_micrel_workaround.patch target/linux/coldfire/image/Makefile target/linux/ep93xx/image/Makefile target/linux/etrax/image/Makefile target/linux/gemini/image/Makefile target/linux/generic-2.6/config-2.6.33 target/linux/generic-2.6/config-2.6.34 target/linux/generic-2.6/patches-2.6.33/007-squashfs_make_lzma_available.patch target/linux/generic-2.6/patches-2.6.33/014-samsung_flash target/linux/generic-2.6/patches-2.6.33/020-mips_multi_machine_support.patch target/linux/generic-2.6/patches-2.6.33/030-pci_disable_common_quirks.patch target/linux/generic-2.6/patches-2.6.33/060-block2mtd_init.patch target/linux/generic-2.6/patches-2.6.33/100-netfilter_layer7_2.21.patch target/linux/generic-2.6/patches-2.6.33/110-netfilter_match_speedup.patch target/linux/generic-2.6/patches-2.6.33/150-netfilter_imq.patch target/linux/generic-2.6/patches-2.6.33/202-mips_mem_functions_performance.patch target/linux/generic-2.6/patches-2.6.33/203-slab_maxsize.patch target/linux/generic-2.6/patches-2.6.33/205-skb_padding.patch target/linux/generic-2.6/patches-2.6.33/210-mini_fo_2.6.25_fixes.patch target/linux/generic-2.6/patches-2.6.33/212-mini_fo_2.6.26_fixes.patch target/linux/generic-2.6/patches-2.6.33/400-ledtrig_morse.patch target/linux/generic-2.6/patches-2.6.33/402-ledtrig_netdev.patch target/linux/generic-2.6/patches-2.6.33/511-yaffs-cvs-2009-04-24.patch target/linux/generic-2.6/patches-2.6.33/903-hostap_txpower.patch target/linux/generic-2.6/patches-2.6.33/924-cs5535_gpio.patch target/linux/generic-2.6/patches-2.6.33/940-wireless_mesh_header.patch target/linux/generic-2.6/patches-2.6.33/971-ocf_20080917.patch target/linux/generic-2.6/patches-2.6.33/980-vm_exports.patch target/linux/generic-2.6/patches-2.6.33/998-openwrt_lzma_options.patch target/linux/goldfish/image/Makefile target/linux/iop32x/image/Makefile target/linux/malta/Makefile target/linux/malta/README target/linux/malta/image/Makefile target/linux/mpc52xx/image/Makefile target/linux/mpc83xx/image/Makefile target/linux/omap35xx/image/Makefile target/linux/ppc40x/config-default target/linux/ppc40x/patches/004-magicbox.patch target/linux/ppc40x/patches/005-openrb.patch target/linux/ps3/image/Makefile target/linux/pxa/image/Makefile target/linux/pxcab/image/Makefile target/linux/ramips/image/Makefile target/linux/ramips/rt288x/config-2.6.32 target/linux/ramips/rt305x/config-2.6.32 target/linux/s3c24xx/image/Makefile target/linux/sibyte/image/Makefile target/linux/ubicom32/image/Makefile target/linux/x86/generic/config-default
60 lines
1.5 KiB
Diff
60 lines
1.5 KiB
Diff
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
|
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
|
@@ -1131,6 +1131,34 @@ static bool ath9k_hw_channel_change(stru
|
|
return true;
|
|
}
|
|
|
|
+bool ath9k_hw_check_alive(struct ath_hw *ah)
|
|
+{
|
|
+ int count = 50;
|
|
+ u32 reg;
|
|
+
|
|
+ if (AR_SREV_9285_10_OR_LATER(ah))
|
|
+ return true;
|
|
+
|
|
+ do {
|
|
+ reg = REG_READ(ah, AR_OBS_BUS_1);
|
|
+
|
|
+ if ((reg & 0x7E7FFFEF) == 0x00702400)
|
|
+ continue;
|
|
+
|
|
+ switch (reg & 0x7E000B00) {
|
|
+ case 0x1E000000:
|
|
+ case 0x52000B00:
|
|
+ case 0x18000B00:
|
|
+ continue;
|
|
+ default:
|
|
+ return true;
|
|
+ }
|
|
+ } while (count-- > 0);
|
|
+
|
|
+ return false;
|
|
+}
|
|
+EXPORT_SYMBOL(ath9k_hw_check_alive);
|
|
+
|
|
int ath9k_hw_reset(struct ath_hw *ah, struct ath9k_channel *chan,
|
|
bool bChannelChange)
|
|
{
|
|
--- a/drivers/net/wireless/ath/ath9k/hw.h
|
|
+++ b/drivers/net/wireless/ath/ath9k/hw.h
|
|
@@ -846,6 +846,7 @@ void ath9k_hw_set11nmac2040(struct ath_h
|
|
void ath9k_hw_beaconinit(struct ath_hw *ah, u32 next_beacon, u32 beacon_period);
|
|
void ath9k_hw_set_sta_beacon_timers(struct ath_hw *ah,
|
|
const struct ath9k_beacon_state *bs);
|
|
+bool ath9k_hw_check_alive(struct ath_hw *ah);
|
|
|
|
bool ath9k_hw_setpower(struct ath_hw *ah, enum ath9k_power_mode mode);
|
|
|
|
--- a/drivers/net/wireless/ath/ath9k/main.c
|
|
+++ b/drivers/net/wireless/ath/ath9k/main.c
|
|
@@ -406,7 +406,8 @@ void ath9k_tasklet(unsigned long data)
|
|
|
|
ath9k_ps_wakeup(sc);
|
|
|
|
- if (status & ATH9K_INT_FATAL) {
|
|
+ if ((status & ATH9K_INT_FATAL) ||
|
|
+ !ath9k_hw_check_alive(ah)) {
|
|
ath_reset(sc, false);
|
|
ath9k_ps_restore(sc);
|
|
return;
|