mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:38:26 +02:00
b460d9e23f
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27940 3c298f89-4303-0410-b956-a3cf2f4a3e73
25 lines
675 B
Diff
25 lines
675 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -559,9 +559,9 @@ endif # $(dot-config)
|
|
all: vmlinux
|
|
|
|
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
|
-KBUILD_CFLAGS += -Os
|
|
+KBUILD_CFLAGS += -Os -fno-caller-saves
|
|
else
|
|
-KBUILD_CFLAGS += -O2
|
|
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
|
|
endif
|
|
|
|
include $(srctree)/arch/$(SRCARCH)/Makefile
|
|
@@ -620,6 +620,9 @@ endif
|
|
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
|
|
+# improve gcc optimization
|
|
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
+
|
|
# warn about C99 declaration after statement
|
|
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
|