mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:38:26 +02:00
aedeeb1874
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13368 3c298f89-4303-0410-b956-a3cf2f4a3e73
34 lines
1.5 KiB
Diff
34 lines
1.5 KiB
Diff
From 2a7fa2dbbf68650644f807a50cc2d84ca30835c1 Mon Sep 17 00:00:00 2001
|
|
From: Maxime Bizon <mbizon@freebox.fr>
|
|
Date: Sun, 21 Sep 2008 04:47:13 +0200
|
|
Subject: [PATCH] [MIPS] BCM63XX: Add PCI support.
|
|
|
|
Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
|
|
---
|
|
arch/mips/bcm63xx/Kconfig | 2 +
|
|
arch/mips/bcm63xx/setup.c | 2 +
|
|
arch/mips/pci/Makefile | 2 +
|
|
arch/mips/pci/fixup-bcm63xx.c | 21 +++
|
|
arch/mips/pci/ops-bcm63xx.c | 179 +++++++++++++++++++++++
|
|
arch/mips/pci/pci-bcm63xx.c | 178 ++++++++++++++++++++++
|
|
arch/mips/pci/pci-bcm63xx.h | 27 ++++
|
|
include/asm-mips/mach-bcm63xx/bcm63xx_dev_pci.h | 6 +
|
|
8 files changed, 417 insertions(+), 0 deletions(-)
|
|
create mode 100644 arch/mips/pci/fixup-bcm63xx.c
|
|
create mode 100644 arch/mips/pci/ops-bcm63xx.c
|
|
create mode 100644 arch/mips/pci/pci-bcm63xx.c
|
|
create mode 100644 arch/mips/pci/pci-bcm63xx.h
|
|
create mode 100644 include/asm-mips/mach-bcm63xx/bcm63xx_dev_pci.h
|
|
|
|
--- a/arch/mips/pci/Makefile
|
|
+++ b/arch/mips/pci/Makefile
|
|
@@ -16,6 +16,8 @@ obj-$(CONFIG_PCI_VR41XX) += ops-vr41xx.o
|
|
obj-$(CONFIG_MARKEINS) += ops-emma2rh.o pci-emma2rh.o fixup-emma2rh.o
|
|
obj-$(CONFIG_PCI_TX4927) += ops-tx4927.o
|
|
obj-$(CONFIG_BCM47XX) += pci-bcm47xx.o
|
|
+obj-$(CONFIG_BCM63XX) += pci-bcm63xx.o fixup-bcm63xx.o \
|
|
+ ops-bcm63xx.o
|
|
|
|
#
|
|
# These are still pretty much in the old state, watch, go blind.
|