mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 00:29:41 +02:00
fb3616ed90
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24800 3c298f89-4303-0410-b956-a3cf2f4a3e73
23 lines
790 B
Diff
23 lines
790 B
Diff
--- a/arch/mips/pci/Makefile
|
|
+++ b/arch/mips/pci/Makefile
|
|
@@ -55,6 +55,7 @@ obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capc
|
|
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
|
|
obj-$(CONFIG_MIKROTIK_RB532) += pci-rc32434.o ops-rc32434.o fixup-rc32434.o
|
|
obj-$(CONFIG_CPU_CAVIUM_OCTEON) += pci-octeon.o pcie-octeon.o
|
|
+obj-$(CONFIG_ADM5120) += pci-adm5120.o
|
|
|
|
ifdef CONFIG_PCI_MSI
|
|
obj-$(CONFIG_CPU_CAVIUM_OCTEON) += msi-octeon.o
|
|
--- a/include/linux/pci_ids.h
|
|
+++ b/include/linux/pci_ids.h
|
|
@@ -1752,6 +1752,9 @@
|
|
#define PCI_VENDOR_ID_ESDGMBH 0x12fe
|
|
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
|
|
|
|
+#define PCI_VENDOR_ID_ADMTEK 0x1317
|
|
+#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
|
|
+
|
|
#define PCI_VENDOR_ID_SIIG 0x131f
|
|
#define PCI_SUBVENDOR_ID_SIIG 0x131f
|
|
#define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000
|