1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-07 18:18:54 +03:00
openwrt-xburst/package/madwifi/patches/200-no_debug.patch
nbd 7f93038dad madwifi: switch to latest madwifi-hal-0.9.30.13 snapshot as reference
merge in refcount branch as well and clean up openwrt patches (a few fixes got merged upstream)


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7300 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-05-21 06:25:34 +00:00

161 lines
6.4 KiB
Diff

diff -urN madwifi-ng-refcount-r2313-20070505.old/ath/if_ath.c madwifi-ng-refcount-r2313-20070505.dev/ath/if_ath.c
--- madwifi-ng-refcount-r2313-20070505.old/ath/if_ath.c 2007-05-13 18:17:56.449987336 +0200
+++ madwifi-ng-refcount-r2313-20070505.dev/ath/if_ath.c 2007-05-13 18:17:56.457986120 +0200
@@ -75,7 +75,7 @@
#include <net80211/if_llc.h>
#endif
-#define AR_DEBUG
+#undef AR_DEBUG
#include "net80211/if_athproto.h"
#include "if_athvar.h"
@@ -359,7 +359,7 @@
ath_keyprint(sc, __func__, ix, hk, mac); \
} while (0)
#else /* defined(AR_DEBUG) */
-#define IFF_DUMPPKTS(sc, _m) netif_msg_dumppkts(&sc->sc_ic)
+#define IFF_DUMPPKTS(sc, _m) 0
#define DPRINTF(sc, _m, _fmt, ...)
#define KEYPRINTF(sc, k, ix, mac)
#endif /* defined(AR_DEBUG) */
diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/amrr/amrr.c madwifi-ng-refcount-r2313-20070505.dev/ath_rate/amrr/amrr.c
--- madwifi-ng-refcount-r2313-20070505.old/ath_rate/amrr/amrr.c 2007-04-09 23:08:06.000000000 +0200
+++ madwifi-ng-refcount-r2313-20070505.dev/ath_rate/amrr/amrr.c 2007-05-13 18:17:56.457986120 +0200
@@ -69,7 +69,7 @@
#include "amrr.h"
-#define AMRR_DEBUG
+#undef AMRR_DEBUG
#ifdef AMRR_DEBUG
#define DPRINTF(sc, _fmt, ...) do { \
if (sc->sc_debug & 0x10) \
diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/minstrel/minstrel.c madwifi-ng-refcount-r2313-20070505.dev/ath_rate/minstrel/minstrel.c
--- madwifi-ng-refcount-r2313-20070505.old/ath_rate/minstrel/minstrel.c 2007-05-13 18:17:55.605115776 +0200
+++ madwifi-ng-refcount-r2313-20070505.dev/ath_rate/minstrel/minstrel.c 2007-05-13 18:17:56.458985968 +0200
@@ -116,7 +116,7 @@
#include "minstrel.h"
-#define MINSTREL_DEBUG
+#undef MINSTREL_DEBUG
#ifdef MINSTREL_DEBUG
enum {
ATH_DEBUG_RATE = 0x00000010 /* rate control */
diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/onoe/onoe.c madwifi-ng-refcount-r2313-20070505.dev/ath_rate/onoe/onoe.c
--- madwifi-ng-refcount-r2313-20070505.old/ath_rate/onoe/onoe.c 2007-04-09 23:08:06.000000000 +0200
+++ madwifi-ng-refcount-r2313-20070505.dev/ath_rate/onoe/onoe.c 2007-05-13 18:17:56.458985968 +0200
@@ -65,7 +65,7 @@
#include "onoe.h"
-#define ONOE_DEBUG
+#undef ONOE_DEBUG
#ifdef ONOE_DEBUG
enum {
ATH_DEBUG_RATE = 0x00000010, /* rate control */
diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/sample/sample.c madwifi-ng-refcount-r2313-20070505.dev/ath_rate/sample/sample.c
--- madwifi-ng-refcount-r2313-20070505.old/ath_rate/sample/sample.c 2007-04-09 23:08:06.000000000 +0200
+++ madwifi-ng-refcount-r2313-20070505.dev/ath_rate/sample/sample.c 2007-05-13 18:17:56.459985816 +0200
@@ -67,7 +67,7 @@
#include "sample.h"
-#define SAMPLE_DEBUG
+#undef SAMPLE_DEBUG
#ifdef SAMPLE_DEBUG
enum {
ATH_DEBUG_RATE = 0x00000010 /* rate control */
diff -urN madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_proto.c madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_proto.c
--- madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_proto.c 2007-02-01 21:49:37.000000000 +0100
+++ madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_proto.c 2007-05-13 18:17:56.460985664 +0200
@@ -312,6 +312,7 @@
}
EXPORT_SYMBOL(ieee80211_print_essid);
+#ifdef IEEE80211_DEBUG
void
ieee80211_dump_pkt(struct ieee80211com *ic,
const u_int8_t *buf, int len, int rate, int rssi)
@@ -390,6 +391,7 @@
}
}
EXPORT_SYMBOL(ieee80211_dump_pkt);
+#endif /* IEEE80211_DEBUG */
int
ieee80211_fix_rate(struct ieee80211_node *ni, int flags)
diff -urN madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_proto.h madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_proto.h
--- madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_proto.h 2007-01-30 05:01:29.000000000 +0100
+++ madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_proto.h 2007-05-13 18:17:56.460985664 +0200
@@ -247,7 +247,11 @@
#endif
int ieee80211_new_state(struct ieee80211vap *, enum ieee80211_state, int);
void ieee80211_print_essid(const u_int8_t *, int);
+#ifdef IEEE80211_DEBUG
void ieee80211_dump_pkt(struct ieee80211com *, const u_int8_t *, int, int, int);
+#else
+#define ieee80211_dump_pkt(...)
+#endif
struct sk_buff *ieee80211_getcfframe(struct ieee80211vap *, int);
/*
diff -urN madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_var.h madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_var.h
--- madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_var.h 2007-05-13 18:17:56.107039472 +0200
+++ madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_var.h 2007-05-13 18:17:56.461985512 +0200
@@ -37,7 +37,7 @@
/*
* Definitions for IEEE 802.11 drivers.
*/
-#define IEEE80211_DEBUG
+#undef IEEE80211_DEBUG
#undef IEEE80211_DEBUG_REFCNT /* node refcnt stuff */
#include <net80211/ieee80211_linux.h>
diff -urN madwifi-ng-refcount-r2313-20070505.old/tools/do_multi.c madwifi-ng-refcount-r2313-20070505.dev/tools/do_multi.c
--- madwifi-ng-refcount-r2313-20070505.old/tools/do_multi.c 2007-05-13 18:17:55.192178552 +0200
+++ madwifi-ng-refcount-r2313-20070505.dev/tools/do_multi.c 2007-05-13 18:17:56.461985512 +0200
@@ -9,16 +9,20 @@
progname = basename(argv[0]);
+#if 0
if(strcmp(progname, "80211debug") == 0)
ret = a80211debug_init(argc, argv);
+#endif
if(strcmp(progname, "80211stats") == 0)
ret = a80211stats_init(argc, argv);
if(strcmp(progname, "athchans") == 0)
ret = athchans_init(argc, argv);
if(strcmp(progname, "athctrl") == 0)
ret = athctrl_init(argc, argv);
+#if 0
if(strcmp(progname, "athdebug") == 0)
ret = athdebug_init(argc, argv);
+#endif
if(strcmp(progname, "athkey") == 0)
ret = athkey_init(argc, argv);
if(strcmp(progname, "athstats") == 0)
diff -urN madwifi-ng-refcount-r2313-20070505.old/tools/Makefile madwifi-ng-refcount-r2313-20070505.dev/tools/Makefile
--- madwifi-ng-refcount-r2313-20070505.old/tools/Makefile 2007-05-13 18:17:55.192178552 +0200
+++ madwifi-ng-refcount-r2313-20070505.dev/tools/Makefile 2007-05-13 18:17:56.461985512 +0200
@@ -52,7 +52,7 @@
ifdef DOMULTI
OBJS= do_multi.o athstats.o 80211stats.o athkey.o athchans.o athctrl.o \
- athdebug.o 80211debug.o wlanconfig.o
+ wlanconfig.o
ALL= ${OBJS} madwifi_multi
endif
@@ -85,7 +85,7 @@
${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
madwifi_multi:
${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
- for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
+ for i in athstats 80211stats athkey athchans athctrl wlanconfig; do \
ln -s -f madwifi_multi $$i; \
done